Bug 25753 - kdm crashes at startup
kdm crashes at startup
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
Florence RC-1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 16:07 EST by Markku Kolkka
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-03 12:45:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markku Kolkka 2001-02-02 16:07:17 EST
On runlevel 5 with kdm as login manager, X exits immediately after 
starting, then restarts. This continues until init decides to stop 
respawning kdm. KDE starts normally with startx from runlevel 3, so the 
problem seems to be in kdm, and the message log supports this:

Feb  2 21:28:39 localhost helmiA   2 21:28:39 linuxconf: Running 
Linuxconf hooks:  succeeded
Feb  2 21:28:44 localhost modprobe: modprobe: Can't locate module 
char-major-145
Feb  2 21:28:44 localhost modprobe: modprobe: Can't locate module 
char-major-145
Feb  2 21:28:44 localhost kernel: [drm:r128_init] *ERROR* Cannot 
initialize agpgart module.
Feb  2 21:28:46 localhost modprobe: modprobe: Can't locate module 
char-major-145
Feb  2 21:28:46 localhost modprobe: modprobe: Can't locate module 
char-major-145
Feb  2 21:28:46 localhost kernel: [drm:r128_init] *ERROR* Cannot 
initialize agpgart module.
Feb  2 21:28:51 localhost kdm[705]: Unknown session exit code 253 from 
process 720
Feb  2 21:28:53 localhost modprobe: modprobe: Can't locate module 
char-major-145
Feb  2 21:28:53 localhost modprobe: modprobe: Can't locate module 
char-major-145
Feb  2 21:28:53 localhost kernel: [drm:r128_init] *ERROR* Cannot 
initialize agpgart module.
Feb  2 21:28:55 localhost modprobe: modprobe: Can't locate module 
char-major-145
Feb  2 21:28:55 localhost modprobe: modprobe: Can't locate module 
char-major-145
Feb  2 21:28:55 localhost kernel: [drm:r128_init] *ERROR* Cannot 
initialize agpgart module.
Feb  2 21:28:57 localhost kdm[730]: Unknown session exit code 253 from 
process 743

... etc.

The XFree86 log has one error message:

[drm] failed to load kernel module "r128"
(0): [drm] drmOpen failed
(EE) R128(0): DRIScreenInit failed!

System configuration:
MSI K7T Pro2 motherboard
AMD Duron 750 MHz CPU
128 MB SDRAM
ATI XPERT 2000 Pro display card (Rage 128 Pro PF AGP)

Fisher installed as KDE-only workstation

The system worked correctly with RH7.0, KDE2.0.1 and XFree86 4.0.2
Comment 1 Glen Foster 2001-02-02 17:57:50 EST
We (Red Hat) should really fix this before next release
Comment 2 David Paschal 2001-02-02 22:33:42 EST
I don't know if this is related, but on my system (see bug 25829), I get a
dialog box stating that kdm crashed and caused signal 11 (SIGSEGV).  A backtrace
is available, but there's no option to save it to a file, and the "Copy" button
does no good since I can't start up a terminal window to paste the text.
Comment 3 Todd Wright 2001-02-03 12:28:25 EST
Same with me.
System is fine on run level 3 but i get a signal 11 (SIGSEGV)on run
level 5. I have both KDE and Gnome installed with a Geforce 2 GTS card.
Comment 4 Bernhard Rosenkraenzer 2001-02-03 12:45:10 EST
Read the release notes to find out what's happening, why it is happening and
what you can
do about it.
Comment 5 sandy 2001-02-04 23:31:17 EST
This happens with me too.  I read release notes ... no help found.
Could you please be more specific
Comment 6 Bernhard Rosenkraenzer 2001-02-05 05:20:29 EST
Install the i386 version of glibc, the i686 version is broken.

Note You need to log in before you can comment on or make changes to this bug.