Bug 25756 - RFE: --test should implicitly assume --notriggers
Summary: RFE: --test should implicitly assume --notriggers
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: Patch
: 49665 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-02 21:29 UTC by kenneth_porter
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 17:54:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.28 KB, patch)
2005-06-07 19:31 UTC, Paul Nasrat
no flags Details | Diff

Description kenneth_porter 2001-02-02 21:29:09 UTC
Issuing an install or upgrade command with --test should do a dry-run without affecting the system. However, some scripts apparently run. In 
particular, upgrading wu-ftpd from RH 6.1 to the latest version appears to run an uninstall script from the old version that attempts to delete 
the wu-ftpd module from linuxconf's config file. This should not happen with --test.

Comment 1 Jeff Johnson 2001-07-24 03:14:08 UTC
*** Bug 49665 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Roesen 2005-06-04 22:28:52 UTC
I do still think this is a good idea... any chance?

Comment 3 Paul Nasrat 2005-06-07 19:31:25 UTC
Created attachment 115197 [details]
proposed patch

Completely untested atm.

Comment 4 Paul Nasrat 2005-09-29 17:54:55 UTC
Commited to rpm-4.4.x branch of upstream rpm.


Note You need to log in before you can comment on or make changes to this bug.