Bug 25781 - diskdruid cannot create / partition on 2nd drive when no space on 1st drive
diskdruid cannot create / partition on 2nd drive when no space on 1st drive
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 18:44 EST by Jeroen Janssen
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 13:58:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeroen Janssen 2001-02-02 18:44:58 EST
Using Workstation installation, selecting DiskDruid to partition my drives.

I have
hda: free 0M
hdc: free 29078M

I want to create a root / partition (size 8192M) on hdc and disk-druid 
tells me that there is "not enough free space" on the device.

(I don't want any linux partitions on hda, so maybe the problem is that 
the / has to be on hda in order to be able to boot? - is that correct?)

ps: I'm able to create a /home partition of 8192M without any problems, 
it's "just" the root that I'm unable to create correctly.
Comment 1 Douglas Kilpatrick 2001-02-03 18:52:36 EST
Assuming this is related to the problem I had:

I have three of the exact same HD, an IBM 45GB IDE (IBM-DTLA-307045).  The BIOS
translates
its real geometry (89355/16/63) to 5606/255/63 when its on ide0 or ide1 (the Via
vt82c686a), but not when its on ide2 or ide3 (pdc20265).

On ide2 or ide3, Disk druid gets the number of cylinders completely wrong.  Disk
druid thinks it has something like 23819 cylinders ( "(gdb) print
(short)89355").  I'm not sure of the number, but its in the 10-20 thousands
somewhere.  Needless to say, this makes creating raid-sets tricky.  I was able
to get it working by doing the formatting w/ fdisk (which worked fine) and
setting the type manually.  When I went back into diskdruid to merge the
partitions into raid sets, Disk Druid claimed I was using ~350% of my HD... but
things appear to work fine.
Comment 2 Michael Fulbright 2001-02-06 13:58:06 EST
First, the problem with detecting the number of cylinders > 64k should be fixed
in our internal tree. The kernel ioctl() we were using did not work above 64k
cylinders.

Secondly, the error message you got is somewhat confusing. It is trying to tell
you that you cannot make the / partition that large because it would extend
beyound the 1024 cylinder limit required for the partition holding the kernel.
Try making a 50 meg /boot partition and it should work.
Comment 3 Jeroen Janssen 2001-02-06 14:16:47 EST
Ok, I tried creating a 50M /boot (on hdc, since hda doesn't have any space
left). 
Now I get "could't fit boot partition" (but I have plenty of space left on hdc)

If I try and put a 1M /boot on hda I get "not enough free space" (wich is
correct).

Note You need to log in before you can comment on or make changes to this bug.