Bug 257821 - perl doesn't support weak references
perl doesn't support weak references
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
8
All All
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 15:41 EDT by Christopher Beland
Modified: 2008-03-07 10:30 EST (History)
3 users (show)

See Also:
Fixed In Version: perl-5.8.8-36.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 10:30:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2007-08-27 15:41:49 EDT
I was trying to start a Catalyst app which works fine with Perl packages as
downloaded from CPAN using the "cpan" command-line interface.

Instead of using CPAN packages, I decided to try the modules supplied as RPMs by
Fedora.  Upon startup, the app complains:

 Weak references are not implemented in the version of perl at
  /usr/lib/perl5/vendor_perl/5.8.8/Catalyst.pm line 22

This is apparently due to a missing Scalar::Util::weaken, as described at: 
 http://search.cpan.org/dist/Task-Weaken/lib/Task/Weaken.pm

RPM versions:
perl-5.8.8-18.fc7
perl-Catalyst-Runtime-5.7007-4.fc7
Comment 1 Marcela Mašláňová 2008-02-26 07:26:20 EST
Did it work when you use Scalar::Util from RPM? 

Thank you for the above link, but I checked perl packages which includes the
Scalar::Util and here is XS compiled. Also the package Scalar::Util use XS support. 
Comment 2 Christopher Beland 2008-02-29 22:26:18 EST
I'm afraid I don't entirely understand what you are saying.  Scalar::Util is
included in the "perl" RPM.  So for example when I upgraded to perl-5.8.8-33.fc8
from the previous Fedora 8 perl RPM, I started getting the "Weak references are
not implemented" error until I force-installed Scalar::Util from CPAN.
Comment 3 Marcela Mašláňová 2008-03-07 10:30:13 EST
The package perl-5.8.8-36 upgrade the Scalar::Util on the latest version. The
problem with XS support, weaken and other functions provided by Scalar::Util
should be fixed by this update.
If you problem persist, please feel free to reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.