Bug 257861 - Duplicate submenus generated when adding a top level submenu. [NEEDINFO]
Duplicate submenus generated when adding a top level submenu.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdebase (Show other bugs)
5.0
All All
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 16:03 EDT by Scott Bambrough
Modified: 2014-06-02 09:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:17:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (scottb)


Attachments (Terms of Use)

  None (edit)
Description Scott Bambrough 2007-08-27 16:03:14 EDT
Description of problem:

Attempting to add a submenu to the top level menu under.  When I do and use KDE
as my desktop, the submenu appears 3 times:  

All Applications/MyMenu
All Applications/Administration/MyMenu
All Applications/Administration/Server Settings/MyMenu.

I was only expecting the submenu at All Applications/My Menu.

The problem seems to be the <DefaultMergeDirs/> entries in system-settings.menu
and server-settings.menu.  If I comment these out the two unexpected submenus
disappear.

Version-Release number of selected component (if applicable):
redhat-menus-6.7.8-1.el5

How reproducible:
All the time.  I can reproduce this without my software as well using this .menu
file:

<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
 "http://www.freedesktop.org/standards/menu-spec/1.0/menu.dtd">
<Menu>
  </Menu>
    <Name>MyMenu</Name>
    <Include>
      <Category>X-Redhat-ServerConfig</Category>
    </Include>
  </Menu>
</Menu>

Steps to Reproduce:

1. Copy the above sample menu file to /etc/xdg/menus/applications-merged.
2. Run update-desktop-database.
3. Look at the menu.
  
Actual results:
Submenus are present at:
All Applications/MyMenu
All Applications/Administration/MyMenu
All Applications/Administration/Server Settings/MyMenu.

Expected results:
Submenu present at:
All Applications/MyMenu

Should not be submenus present at:
All Applications/Administration/MyMenu
All Applications/Administration/Server Settings/MyMenu.

Additional info:
With my application install I get the expected behaviour under Gnome.
Comment 1 Ray Strode [halfline] 2007-08-27 16:21:39 EDT
Seems like a bug in kde's menu parsing code.  From the spec:

 Implementations may chose to use .menu files with names other than
application.menu for tasks or menus other than the main application menu. In
that case the first part of the name of the default merge directory is derived
from the name of the .menu file.

For example in a system that uses a preferences.menu file to describe an
additional menu, the default merge directories included in the
<DefaultMergeDirs> element in the preferences.menu file would become
$XDG_CONFIG_DIRS/menus/preferences-merged/ 

So the server-settings.menu and system-settings.menu files should interpret
<DefaultMergeDirs> to be menus/server-settings-merged and
menu/system-settings-merged respectively, not applications-merged.

Reassigning to kdebase
Comment 2 RHEL Product and Program Management 2014-03-07 07:47:25 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:17:21 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.