Bug 258081 - Error: Cannot retrieve repository metadata (repomd.xml) for repository: %s. Please verify its path and try again
Error: Cannot retrieve repository metadata (repomd.xml) for repository: %s. P...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 279151 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 16:57 EDT by Orion Poplawski
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.2.5-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 23:20:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-08-27 16:57:01 EDT
Description of problem:

I get this message from a yum cron job on a laptop presumably when it doesn't
have internet access:

Error: Cannot retrieve repository metadata (repomd.xml) for repository: %s.
Please verify its path and try again

Two issues:

- The message is not printed properly.  I believe this will fix:

--- /usr/lib/python2.5/site-packages/yum/yumRepo.py.orig        2007-08-27
13:38:48.000000000 -0600
+++ /usr/lib/python2.5/site-packages/yum/yumRepo.py     2007-08-27
13:40:01.000000000 -0600
@@ -720,8 +720,8 @@
         try:
             self._loadRepoXML(text=self)
         except Errors.RepoError, e:
-            msg = "Cannot retrieve repository metadata (repomd.xml) for
repository: %s. " + \
-                  "Please verify its path and try again" % self
+            msg = "Cannot retrieve repository metadata (repomd.xml) for
repository: %s. " \
+                  % self + "Please verify its path and try again"
             raise Errors.RepoError, (msg)
         return self._repoXML


- Second issue is that this is being run with -e 0 and I don't think it should
be printing this error.

Version-Release number of selected component (if applicable):
yum-3.2.3-2.fc7

(This is an updated yum from development build on f7)
Comment 1 Seth Vidal 2007-08-31 00:44:22 EDT
-e0 outputs critical failures - of which this is one. so it's printing out is
correct but the output is, indeed, wrong. Thank you.

I've applied a slight different patch than yours - but thank you for pointing it
out.

Comment 2 Seth Vidal 2007-09-05 15:31:06 EDT
*** Bug 279151 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2007-09-12 12:41:19 EDT
yum-3.2.5-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2007-09-17 23:20:50 EDT
yum-3.2.5-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.