Bug 258301 - Applications using qt-mysql crash if database is removed before QApplication is destroyed
Applications using qt-mysql crash if database is removed before QApplication ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Patch
Depends On: 243722
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 18:27 EDT by Jarod Wilson
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 08:46:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jarod Wilson 2007-08-27 18:27:25 EDT
+++ This bug was initially created as a clone of Bug #243722 +++

Description of problem:
An application doing

    QSqlDatabase::removeDatabase(db);

before the QApplication instance is destroyed may result in the program crashing.

Upstream bug:
http://trolltech.com/developer/task-tracker/index_html?method=entry&id=154194

No patch available there, but SUSE's qt carries a patch for the problem, which
is available in their srpm, buildsystem, or from a list post here:

http://www.gossamer-threads.com/lists/engine?do=post_attachment;postatt_id=10590;list=mythtv

Version-Release number of selected component (if applicable):
qt-3.3.8-4.fc7

-- Additional comment from jwilson@redhat.com on 2007-06-11 11:07 EST --
Created an attachment (id=156722)
qt3 mysql unload crash fix


-- Additional comment from rdieter@math.unl.edu on 2007-06-11 11:12 EST --
Thanks Jarod, have you confirmed the patch works as advertised?

-- Additional comment from jwilson@redhat.com on 2007-06-11 11:20 EST --
Personally, no, not just yet, but it was brought to my attention by some of the
mythtv developers whom I completely trust, and has already been added on top of
qt 3.3.8 in a few other distros with the desired result of eliminating the
crash. Some further details:

http://svn.mythtv.org/trac/ticket/3595
http://www.gossamer-threads.com/lists/mythtv/dev/257269


-- Additional comment from than@redhat.com on 2007-06-14 07:54 EST --
i have backported the fix for #bz243722, it will be included in 
qt-3_3_8-5_fc7_1. I will push new qt in f7 update soon. Thanks for your 
report.

-- Additional comment from gtgj@pacbell.net on 2007-08-25 10:22 EST --
I believe that this bug has not been fixed in f7 yet (qt3)?  It looks like only
the fc6 fixes were released two months ago.
Comment 1 Jarod Wilson 2007-08-27 18:28:49 EDT
Can we *please* get this fixed in F7 too?
Comment 2 Ngo Than 2007-08-29 08:46:37 EDT
it will be pushed into F7-update today

Note You need to log in before you can comment on or make changes to this bug.