Bug 25850 - apparent scsi errors when X is entered and there is no CD in drive
apparent scsi errors when X is entered and there is no CD in drive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-03 08:31 EST by Chris Runge
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 19:33:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2001-02-03 08:31:34 EST
beta 3 (Fisher)

as soon as I startx I get the following in /var/log/messages and printed
out
to the root console:

Feb  2 15:33:34 rockne kernel: (scsi1:A:3): async, 16bit
Feb  2 15:33:34 rockne kernel: (scsi1:A:3): synchronous at 20.0MHz, offset
0xf,
16bit
Feb  2 15:33:34 rockne kernel: (scsi1:A:3): async, 16bit
Feb  2 15:33:34 rockne kernel: (scsi1:A:3): synchronous at 20.0MHz, offset
0xf,
16bit
Feb  2 15:33:34 rockne kernel: (scsi1:A:3): async, 16bit
Feb  2 15:33:34 rockne kernel: (scsi1:A:3): synchronous at 20.0MHz, offset
0xf,
16bit

There are also strange sounds coming from the computer when these messages
are printed. This is the part that concerns me and the main reason I marked
priority/severity as high.

More info:

# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: SEAGATE  Model: ST318404LW       Rev: 0006
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi1 Channel: 00 Id: 03 Lun: 00
  Vendor: PLEXTOR  Model: CD-ROM PX-40TW   Rev: 1.04
  Type:   CD-ROM                           ANSI SCSI revision: 02

The SCSI controller is an on-board Adaptec 7899 dual-channel Ultra/160
controller

The CD-ROM drive was empty. If the drive has a CD in it there are no
problems. If I exit X the problem goes away.

This is with the default GNOME desktop. I noticed that if I change the CD
properties under the Control Panel so that it doesn't try to automount or
autoplay CDs then the problem appears to go away as well.
Comment 1 Michael K. Johnson 2001-02-08 16:36:32 EST
Doug, this looks like Justin's beta driver -- see if this information
is still useful to him.
Comment 2 Doug Ledford 2001-02-09 06:08:44 EST
This would be a description of what happens when magicdev (part of the gnome
desktop) is querying the CD-ROM drive every so often to see if there is a CD in
the drive.  Obviously, it's causing a lot of renegotiations in the driver (my
driver was having the same problem so I modified it to only renegotiate if the
returned SENSE info included something about a parity error or similar).  The
part about making noise is likely something to do with the CD-ROM drive itself
and probably doesn't matter which driver you are using (unless there are a lot
of bus device resets being delivered).  I'll forward to Justin Gibbs at Adaptec.
Comment 3 Justin T. Gibbs 2001-02-12 14:34:26 EST
Version 6.1.1 of the aic7xxx driver will now only report negotiation messages
if the result of the negotiation differs from that last reported (unless you
have verbose messages turned on in the driver).  This will remove the messages
but, as Doug mentioned, the sound your CD drive makes when the system queries
it for media is something you'll have to take up with the hardware vendor.

Doug's change to his driver to only do the negotiation if sense data indicates
a pariticular type of error sounds dangerous.  The sense retrieval may hang the
bus if, for instance, the target has been power cycled or reset by another
initiator prior to reporting the check condition.  If that is the case, our
prior negotiation status has been invalidated and attempting to transfer at
the certainly require recovery.  If the recovery results in a bus reset, then
some operations on "innocent targets" (tape writes, a cd burning session) will
be uncorrectably terminated.

Note You need to log in before you can comment on or make changes to this bug.