Bug 259301 - arpwatch tries to use /usr/lib/sendmail
arpwatch tries to use /usr/lib/sendmail
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tcpdump (Show other bugs)
5.0
All All
medium Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 04:30 EDT by Pekka Savola
Modified: 2012-02-03 03:59 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0321
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:54:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2007-08-28 04:30:19 EDT
Description of problem:
Arpwatch tries to use /usr/lib/sendmail to to send its mails but it does not exist.

This results in the following kind of log messages:
Aug 28 11:19:01 otso arpwatch: execl: /usr/lib/sendmail: No such file or directory

Version-Release number of selected component (if applicable):
arpwatch-2.1a13-15.8.1

How reproducible:
strings /usr/sbin/arpwatch | grep sendmail

If it's /usr/lib/sendmail, it's broken.

Actual results:
/usr/lib/sendmail

Expected results:
/usr/sbin/sendmail

Additional info:

Recompiling sendmail on a system that includes /usr/sbin/sendmail fixes this. 
The problem is in that the spec file should have 'Requires: /usr/sbin/sendmail'
or similar so that it pulls in the right dependencies at build time.

Note: tested on CentOS 5 but the problem is believed to be the same.
Comment 1 Miroslav Lichvar 2007-08-29 11:12:53 EDT
Thanks for the report.

Most MTAs provide also /usr/lib/sendmail, but using /usr/sbin/sendmail is
certainly better.
Comment 2 RHEL Product and Program Management 2007-10-19 16:26:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 errata-xmlrpc 2008-05-21 12:54:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0321.html

Note You need to log in before you can comment on or make changes to this bug.