Bug 25938 - up2date reports invalid server certificate
Summary: up2date reports invalid server certificate
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-04 02:11 UTC by Jim Phillips
Modified: 2007-04-18 16:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 04:51:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jim Phillips 2001-02-04 02:11:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i586)


I just installed fisher.  The first thing I wanted to do was run up2date. 
I ran the rhn registration and entered my rhn login/pass to complete the
wizard.  When I ran up2date, I got this error:
There was a fatal error communicating with the server.  The message was:
Invalid server certificate

Reproducible: Always
Steps to Reproduce:
1.  Run up2date
2.  Click Next on the first dialog.
	

Actual Results:  I get this error:
There was a fatal error communicating with the server.  The message was:
Invalid server certificate

Expected Results:  I shouldn't get the above error and up2date should
communicate with the server.

Comment 1 Adrian Likins 2001-02-04 03:41:02 UTC
The up2date servers provided for the beta are different than
the standard up2date servers. These support anonymous registration
only, are hosted on a different set of machines, and only have
the package sets for 7.0 and the beta. Oh, and the server
code is a new version as well (figured we'd might as
well test the beta code with the beta ;->)<p>

To use `up2date` with the beta, you need to run:

	up2date -r

This will create an anonymous registration for up2date. The 
Red Hat Network functionality is not supported for the beta.
Only the up2date fucntionality is supported.
This is covered in the release notes (though admittedly, not
in as much detail as I would have liked....)


Comment 2 Steve Howard 2001-02-06 18:47:18 UTC
I get similar results but my message is:

There was a fatal error communicating with the server. The message was:
Connection refused

Comment 3 Need Real Name 2001-02-07 13:07:42 UTC
I receive the following...

There was a fatal error communicating with the server. The message was: Invalid
Architecture and OS release combination.

Comment 4 Adrian Likins 2001-02-08 04:51:36 UTC
"Invalid Architecture and OS release combination" typically
means that you have a /etc/sysconfig/rhn/system_id from a 
previous registration that that indicates a not supported release.

You probabaly need to rerigster with:

	up2date -r

Also, verify that your "redhat-release" package is accurate,
as the version of that package is how up2date determines what
release you are running.


Comment 5 Preston Brown 2001-02-09 03:38:50 UTC
connection refused came from a period of time when the RHN servers were having a
problem, since corrected. 

If you have an "old" systemid, you need to remove it or back it up while using
the beta, and run 

up2date -r

to create an anonymous system profile for your Fisher Beta install.


Note You need to log in before you can comment on or make changes to this bug.