Bug 25956 - [page_alloc.c:84] Call trace sums.
[page_alloc.c:84] Call trace sums.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Florence Gold
:
: 25957 25959 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-04 01:24 EST by Henri Schlereth
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 15:47:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2001-02-04 01:24:42 EST
I though I submitted this before but since I have more I might as well add a new one.

Jan 14 21:00:00 rock CROND[1136]: (root) CMD (   /sbin/rmmod -as) 
Jan 14 21:42:02 rock kernel: kernel BUG at page_alloc.c:84!
Jan 14 21:42:02 rock kernel: invalid operand: 0000
Jan 14 21:42:02 rock kernel: CPU:    0
Jan 14 21:42:02 rock kernel: EIP:    0010:[__free_pages_ok+75/912]
Jan 14 21:42:02 rock kernel: EIP:    0010:[<c012d21b>]
Jan 14 21:42:02 rock kernel: EFLAGS: 00010282
Jan 14 21:42:02 rock kernel: eax: 0000001f   ebx: c10c888c   ecx: 00000002   edx: 00000000
Jan 14 21:42:02 rock kernel: esi: c10c888c   edi: 00000000   ebp: 00000007   esp: c1165f7c
Jan 14 21:42:02 rock kernel: ds: 0018   es: 0018   ss: 0018
Jan 14 21:42:02 rock kernel: Process kflushd (pid: 5, stackpage=c1165000)
Jan 14 21:42:02 rock kernel: Stack: c01fd882 c01fdb30 00000054 c1117cdc c0134dea 00000003 c2f34200 c10c888c 
Jan 14 21:42:02 rock kernel:        c10c88b4 c10c888c 00000000 00000007 c012c499 00000000 00000000 00000000 
Jan 14 21:42:02 rock kernel:        00000112 00001573 00000000 c1164000 00000044 c483b760 0008e000 c013519b 
Jan 14 21:42:02 rock kernel: Call Trace: [tvecs+10014/76648] [tvecs+10700/76648] [try_to_free_buffers+250/304] [page_launder+1257/2032] 
[3c503:__insmod_3c503_O/lib/modules/2.4.0-0.43.12/kernel/drivers/n+-358560/96] [bdflush+139/272] [empty_bad_page+0/4096] 
Jan 14 21:42:02 rock kernel: Call Trace: [<c01fd882>] [<c01fdb30>] [<c0134dea>] [<c012c499>] [<c483b760>] [<c013519b>] [<c0105000>] 
Jan 14 21:42:02 rock kernel:        [kernel_thread+38/48] [bdflush+0/272] 
Jan 14 21:42:02 rock kernel:        [<c0108b26>] [<c0135110>] 
Jan 14 21:42:02 rock kernel: Code: 0f 0b 83 c4 0c 89 da 8b 2d f8 e3 29 c0 29 ea 89 d0 c1 e0 04 
Jan 14 21:42:02 rock kernel: kernel BUG at vmscan.c:533!
Jan 14 21:42:02 rock kernel: invalid operand: 0000
Jan 14 21:42:02 rock kernel: CPU:    0
Jan 14 21:42:02 rock kernel: EIP:    0010:[reclaim_page+885/976]
Jan 14 21:42:02 rock kernel: EIP:    0010:[<c012bf55>]
Jan 14 21:42:02 rock kernel: EFLAGS: 00010282
Jan 14 21:42:02 rock kernel: eax: 0000001c   ebx: c10c888c   ecx: 00000004   edx: 00000000
Jan 14 21:42:02 rock kernel: esi: c10c888c   edi: c10c88a8   ebp: 0000035a   esp: c1d5bed0
Jan 14 21:42:02 rock kernel: ds: 0018   es: 0018   ss: 0018
Jan 14 21:42:02 rock kernel: Process mv (pid: 1286, stackpage=c1d5b000)
Jan 14 21:42:02 rock kernel: Stack: c01fd102 c01fd3a1 00000215 c0236d38 c0236f10 00000002 00000001 c012d89a 
Jan 14 21:42:02 rock kernel:        c0236d38 00000000 c0236f18 00000000 00000005 c012d9f1 c0236f0c 00000000 
Jan 14 21:42:02 rock kernel:        00000002 00000001 00000001 c0236f0c 00000000 c112f11c 00000000 000000ab 
Jan 14 21:42:02 rock kernel: Call Trace: [tvecs+8094/76648] [tvecs+8765/76648] [__alloc_pages_limit+122/176] [__alloc_pages+289/736] 
[generic_file_write+592/1024] [3c503:__insmod_3c503_O/lib/modules/2.4.0-0.43.12/kernel/drivers/n+-76247/96] [sys_write+150/208] 
Jan 14 21:42:02 rock kernel: Call Trace: [<c01fd102>] [<c01fd3a1>] [<c012d89a>] [<c012d9f1>] [<c0128010>] [<c4880629>] [<c01314f6>] 
Jan 14 21:42:02 rock kernel:        [system_call+51/64] 
Jan 14 21:42:02 rock kernel:        [<c010a583>] 
Jan 14 21:42:02 rock kernel: Code: 0f 0b 83 c4 0c 31 c0 0f b3 43 18 8d 43 2c 8d 73 28 39 43 2c
Comment 1 Arjan van de Ven 2001-02-05 04:18:50 EST
Is this a machine with > 1Gb of RAM ?
Comment 2 Henri Schlereth 2001-02-05 15:16:55 EST
Umm, that would be nice but no. It has 64MB.

Machine ID/name: #2/rock

CPU: Intel Pentium 100 1
Memory: 65MB 1
Motherboard: N/A 1
Video: Trident Microsystems 3DIm`age 975 (rev f3) 5
Storage: Quantum Fireball EX6.4a ATA 6149MB 1
         Quantum Fireball Ct10 05 ATA 4884MB 1
         TEAC CD-W54E (CD-RW) 1
         IOMEGA ZIP 100 ATAPI, ATAPI FLOPPY DRIVE 1
Network: 3c503 Etherlink II-TP ISA 2
Sound:   Creative Labs SoundBlaster 16/DSP 2 * 

lspci:

00:00.0 Host bridge: Intel Corporation 430FX - 82437FX TSC [Triton I] (rev 02)
00:07.0 ISA bridge: Intel Corporation 82371FB PIIX ISA [Triton I] (rev 02)
00:07.1 IDE interface: Intel Corporation 82371FB PIIX IDE [Triton I] (rev 02)
00:09.0 VGA compatible controller: Trident Microsystems 3DIm`age 975 (rev f3)

lspci -n:

00:00.0 Class 0600: 8086:122d (rev 02)
00:07.0 Class 0601: 8086:122e (rev 02)
00:07.1 Class 0101: 8086:1230 (rev 02)
00:09.0 Class 0300: 1023:9750 (rev f3)

Bugzilla entries:

#15453 Multiple Issues with XFree86-SVGA and Trident 3DImage 9750

Note: this is a dual boot win95a/linux box and as such I only use it
in the custom install/upgrade portion of the beta cycle.

* Detected and works just fine with sndconfig.
Comment 3 Glen Foster 2001-02-05 17:46:16 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 4 Michael K. Johnson 2001-02-08 17:25:20 EST
*** Bug 25957 has been marked as a duplicate of this bug. ***
Comment 5 Michael K. Johnson 2001-02-08 17:25:50 EST
*** Bug 25959 has been marked as a duplicate of this bug. ***
Comment 6 Michael K. Johnson 2001-02-28 21:57:25 EST
Was this a one-time thing or is it repeatable?

Have you tested the wolverine kernel or the newer 2.4.1-0.1.14 kernel
in rawhide?
Comment 7 Henri Schlereth 2001-03-01 00:30:18 EST
I really cant tell if the call trace for 25961 belows there or here. However, I my experience I usually get less grief when I
install the i386 kernel instead of the i586 kernel that the installer puts in. This has alway been my frankenbox.
Comment 8 Henri Schlereth 2001-03-12 15:56:58 EST
I am now running RC2 and will put thru a heavy load of similair activities to see if I can generate the same problems.
Until then since I havent seen anyone else either add to this or generate their own 'zilla's in this matter I will close this
out as a possible quirk of the franken-box since I cant get the same behaviour in the other test machines.

Note You need to log in before you can comment on or make changes to this bug.