Bug 259681 - need to enhance getaddrinfo to support optimistic addresses
need to enhance getaddrinfo to support optimistic addresses
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: glibc (Show other bugs)
5.0
All All
high Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks: 221859 253764 372911
  Show dependency treegraph
 
Reported: 2007-08-28 07:35 EDT by Neil Horman
Modified: 2008-05-21 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0083
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:52:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add optimistic support to getaddrinfo (832 bytes, patch)
2007-08-28 07:35 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Neil Horman 2007-08-28 07:35:33 EDT
Description of problem:
RFC 4429 requires that addresses flagged as optimistic be treated as depricated
addresses.  Since getaddrinfo attempts to organize addresses according to the
priority laid out in RFC 3484, and IFA_F_OPTIMISTIC is a separate kernel flag,
we need to update getaddrinfo to recognize this flag and handle it accordingly.
Comment 1 Neil Horman 2007-08-28 07:35:33 EDT
Created attachment 175961 [details]
patch to add optimistic support to getaddrinfo
Comment 2 Ulrich Drepper 2007-08-29 13:00:46 EDT
The patch is upstream.
Comment 3 Jakub Jelinek 2007-09-19 03:26:53 EDT
Change is so far in rawhide glibc-2.6.90-14.
Comment 4 RHEL Product and Program Management 2007-10-15 23:43:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Neil Horman 2007-11-30 15:58:03 EST
Jakub, can you tell me if this is inglibc for 5.2 yet?  Thanks!
Comment 6 Lawrence Lim 2007-12-21 10:04:46 EST
Need this for IPv6. QE Ack.
Comment 7 Irina Boverman 2007-12-21 10:09:13 EST
We need this fix in rhel 5.2 to meet IPV6DoD testing requirements. Jakub, can
you please answer the question above?
Comment 10 Neil Horman 2008-01-04 16:51:48 EST
yes, to both question, in RHEL5.2
Comment 11 Jakub Jelinek 2008-01-08 04:08:17 EST
BTW, the linux-2.6-net-ipv6-backport-optimistic-dad.patch patch changes userland
API, which is very undesirable for RHEL5.  linux/rtnetlink.h just should for RHEL5
the newly added linux/if_addr.h header, or instead of creating a new header the
new stuff should be just added directly into linux/rtnetlink.h.
Comment 15 errata-xmlrpc 2008-05-21 12:52:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0083.html

Note You need to log in before you can comment on or make changes to this bug.