This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 259741 - Setting the root password from firstboot is broken
Setting the root password from firstboot is broken
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-rootpassword (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
: 214962 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 07:49 EDT by Matthias Hensler
Modified: 2009-01-07 13:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 07:09:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Do not change sensitivity of confirmEntry widget otherwise no input is possible since activation gets never called (690 bytes, patch)
2007-08-28 07:49 EDT, Matthias Hensler
no flags Details | Diff

  None (edit)
Description Matthias Hensler 2007-08-28 07:49:38 EDT
Description of problem:
The firstboot part of system-config-rootpassword does not allow to set a proper
root password. In fact you can only skip the dialog resulting in an empty root
password (bad!).


Version-Release number of selected component (if applicable):
system-config-rootpassword-1.1.10-1

(Reading the changelog of the rawhide version there was no fix yet).

How reproducible:
Install system-config-rootpassword, touch /etc/reconfigSys and reboot

Steps to Reproduce:
1. Start firstboot in reconfig mode
2. Try to set a proper root password
3.
  
Actual results:

The "confirm password" input field is deactivated, you can only type in the
password once but not confirm it. To skip the dialog you have to leave the
password field empty (to match with the confirm password field) resulting in an
empty root password.

Expected results:
Be able to type in the password twice to get it set properly.

Additional info:
The "confirm password" field is deactivated. In the standalone version if will
be activated by the function "activation" (which checks the length and
strongness of the password).

However, in the firstboot version the activation function is never call,
resulting in a still deactivated confirm-field, even if a long and strong
password is typed in.

Simple fix is attached. Better fix would be to add the strongness indicator to
the firstboot dialog as well and call the activation function while typing.
Comment 1 Matthias Hensler 2007-08-28 07:49:38 EDT
Created attachment 176021 [details]
Do not change sensitivity of confirmEntry widget otherwise no input is possible since activation gets never called
Comment 2 Red Hat Bugzilla 2007-10-23 11:24:39 EDT
User pgraner@redhat.com's account has been closed
Comment 3 Lubomir Kundrak 2007-11-20 05:18:34 EST
Matthias: Your patch seems well. I'll import it to devel shortly.
Comment 4 Lubomir Kundrak 2007-11-20 05:27:41 EST
*** Bug 214962 has been marked as a duplicate of this bug. ***
Comment 5 Lubomir Kundrak 2007-11-21 06:49:51 EST
I believe the issue has been fixed in system-config-rootpassword-1.99.0-1
http://koji.fedoraproject.org/koji/taskinfo?taskID=252730
Comment 6 Matthias Hensler 2007-11-27 06:56:34 EST
(In reply to comment #5)
> I believe the issue has been fixed in system-config-rootpassword-1.99.0-1
> http://koji.fedoraproject.org/koji/taskinfo?taskID=252730

I can confirm that the problem is fixed here (tried rawhide version 1.99.2-1).
Comment 7 Lubomir Kundrak 2007-11-27 07:09:36 EST
I also tried with similar results. Thanks for your report and patch -- closing.

Note You need to log in before you can comment on or make changes to this bug.