This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 25975 - Problems at the end of a 6.2 to 7.0 upgrade with anaconda
Problems at the end of a 6.2 to 7.0 upgrade with anaconda
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0J
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-04 09:50 EST by Alex De Winne
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 13:43:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex De Winne 2001-02-04 09:50:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; Tucows)


My system before the attempted upgrade was a redhat 6.2 system. Printing, 
networking....all fine. I decided to upgrade to 7.0 using jp(later found 
out that these were Japanese). Using disc1 to boot, I choose upgrade. I 
changed none of the packages. When asked for disc 2, I inserted, about 1 
minute later a message came up stating the there was a problem and it was 
most likely caused by a bug. The message recommended saving the report to 
floppy and reporting it to bugzilla. 

Reproducible: Always
Steps to Reproduce:
1.install workstation 6.2 on i386
2.upgrade to 7 using jp disc
3.anaconda reports errors	

Actual Results:  Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1552, in 
doInstall
    self.instCallback, p)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1307, in 
instCallback
    self.rpmFD = os.open(fn, os.O_RDONLY)
OSError: [Errno 2] No such file or 
directory: '/mnt/source/RedHat/RPMS/enlightenment-0.16.4-6j1.i386.rpm'

Local variables in innermost frame:
fn: /mnt/source/RedHat/RPMS/enlightenment-0.16.4-6j1.i386.rpm
total: 0
self: <todo.ToDo instance at 84bcde8>
h: <header object at 8ca77f8>
amount: 0
intf: <progress_gui.InstallProgressWindow instance at 850f6c8>
what: 2

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdb'
sS'progressWindow'
p9

<failed>


Expected Results:  completed upgrade
Comment 1 Alex De Winne 2001-02-04 13:18:14 EST
I got around this problem by downloading 7.0-i386-respin disc1/2 and using these
to install instead. I guess that means its not really a bug, but since the
system message reported it as one I thought I'd play it safe and report it.


Note You need to log in before you can comment on or make changes to this bug.