Bug 25979 - going to single mode from init 5 don't work
Summary: going to single mode from init 5 don't work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard: Florence RC-1
Keywords:
: 25500 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-04 17:20 UTC by angus young
Modified: 2014-03-17 02:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 03:05:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description angus young 2001-02-04 17:20:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [fr] (X11; U; Linux 2.2.16-22 i586)


from xterm in root, just want to go in single mode:
init 1
stop all services correctly but after seen stopping fonts settings don't go
in single mode but restart in init 5.
Can reproduce the problem on  2 machines.
Any other information i can tell you...

Reproducible: Always
Steps to Reproduce:
1.xterm: init 1
2.see the last message stopping fonts settings
3.not in init 1 but restart script for init 5

Comment 1 Bill Nottingham 2001-02-05 16:03:08 UTC
In testing, this appears to be a kernel bug.

Comment 2 Bill Nottingham 2001-02-05 16:03:15 UTC
*** Bug 25500 has been marked as a duplicate of this bug. ***

Comment 3 Glen Foster 2001-02-05 22:50:40 UTC
We (Red Hat) should really try hard to fix this before next release.

Comment 4 Arjan van de Ven 2001-02-07 12:09:40 UTC
Works for me on newer kernels.

Comment 5 Bill Nottingham 2001-02-07 23:17:12 UTC
How much newer (version number?)

Comment 6 Bill Nottingham 2001-02-08 00:10:52 UTC
Doesn't work on 0.99.24 here.

Comment 7 Arjan van de Ven 2001-02-12 16:21:50 UTC
Works on .25 here. But my testbox runs the 7.0 glibc rpms.


Comment 8 Michael K. Johnson 2001-02-13 21:22:55 UTC
What version of SysVinit do you have, Arjan?

Comment 9 Bill Nottingham 2001-02-13 22:33:20 UTC
It still fails in 2.4.1-1.6.1 here. I suppose it  could be a glibc
issue as well.

Comment 10 Bill Nottingham 2001-02-14 00:09:23 UTC
Swiching back to 2.1.92-14 didn't help, so it's apparently not glibc.

Comment 11 Matt Wilson 2001-02-14 08:17:49 UTC
This seems to work...

--- ./single.orig	Wed Feb 14 02:21:33 2001
+++ ./single	Wed Feb 14 02:21:38 2001
@@ -54,4 +54,4 @@

 # Now go to the single user level.
 echo $"Telling INIT to go to single user mode."
-exec init -t1 S
+init -t1 S


Comment 12 Bill Nottingham 2001-02-14 23:17:24 UTC
I tried this with both the 7.0 (2.78-10) and 7.1 (2.78-11) SysVinit, same
results.

Comment 13 Bill Nottingham 2001-02-14 23:17:55 UTC
Does it still work for you if you install the errata glibc on top of 7.0?

Comment 14 Arjan van de Ven 2001-02-15 00:49:03 UTC
My box has glibc 2.2-12

Comment 15 Bill Nottingham 2001-02-15 01:30:35 UTC
If you install the SysVinit and glibc from the beta, does it still work for you?


Comment 16 Michael K. Johnson 2001-03-01 03:05:15 UTC
Bill fixing in initscripts, bug in /etc/rc.d/init.d/single

Comment 17 Bill Nottingham 2001-03-01 03:20:31 UTC
Yes, but I'd still love to know why it worked until a new kernel.

Fixed in 5.68-1 or so.

Comment 18 angus young 2001-03-02 14:46:38 UTC
no problem with wolverin for me

Comment 19 Derek Tattersall 2001-03-06 18:00:22 UTC
Can't reproduce with kernel-2.4.2-0.1.20


Note You need to log in before you can comment on or make changes to this bug.