Bug 25979 - going to single mode from init 5 don't work
going to single mode from init 5 don't work
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Florence RC-1
: 25500 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-02-04 12:20 EST by angus young
Modified: 2014-03-16 22:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-28 22:05:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description angus young 2001-02-04 12:20:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [fr] (X11; U; Linux 2.2.16-22 i586)

from xterm in root, just want to go in single mode:
init 1
stop all services correctly but after seen stopping fonts settings don't go
in single mode but restart in init 5.
Can reproduce the problem on  2 machines.
Any other information i can tell you...

Reproducible: Always
Steps to Reproduce:
1.xterm: init 1
2.see the last message stopping fonts settings
3.not in init 1 but restart script for init 5
Comment 1 Bill Nottingham 2001-02-05 11:03:08 EST
In testing, this appears to be a kernel bug.
Comment 2 Bill Nottingham 2001-02-05 11:03:15 EST
*** Bug 25500 has been marked as a duplicate of this bug. ***
Comment 3 Glen Foster 2001-02-05 17:50:40 EST
We (Red Hat) should really try hard to fix this before next release.
Comment 4 Arjan van de Ven 2001-02-07 07:09:40 EST
Works for me on newer kernels.
Comment 5 Bill Nottingham 2001-02-07 18:17:12 EST
How much newer (version number?)
Comment 6 Bill Nottingham 2001-02-07 19:10:52 EST
Doesn't work on 0.99.24 here.
Comment 7 Arjan van de Ven 2001-02-12 11:21:50 EST
Works on .25 here. But my testbox runs the 7.0 glibc rpms.
Comment 8 Michael K. Johnson 2001-02-13 16:22:55 EST
What version of SysVinit do you have, Arjan?
Comment 9 Bill Nottingham 2001-02-13 17:33:20 EST
It still fails in 2.4.1-1.6.1 here. I suppose it  could be a glibc
issue as well.
Comment 10 Bill Nottingham 2001-02-13 19:09:23 EST
Swiching back to 2.1.92-14 didn't help, so it's apparently not glibc.
Comment 11 Matt Wilson 2001-02-14 03:17:49 EST
This seems to work...

--- ./single.orig	Wed Feb 14 02:21:33 2001
+++ ./single	Wed Feb 14 02:21:38 2001
@@ -54,4 +54,4 @@

 # Now go to the single user level.
 echo $"Telling INIT to go to single user mode."
-exec init -t1 S
+init -t1 S
Comment 12 Bill Nottingham 2001-02-14 18:17:24 EST
I tried this with both the 7.0 (2.78-10) and 7.1 (2.78-11) SysVinit, same
Comment 13 Bill Nottingham 2001-02-14 18:17:55 EST
Does it still work for you if you install the errata glibc on top of 7.0?
Comment 14 Arjan van de Ven 2001-02-14 19:49:03 EST
My box has glibc 2.2-12
Comment 15 Bill Nottingham 2001-02-14 20:30:35 EST
If you install the SysVinit and glibc from the beta, does it still work for you?
Comment 16 Michael K. Johnson 2001-02-28 22:05:15 EST
Bill fixing in initscripts, bug in /etc/rc.d/init.d/single
Comment 17 Bill Nottingham 2001-02-28 22:20:31 EST
Yes, but I'd still love to know why it worked until a new kernel.

Fixed in 5.68-1 or so.
Comment 18 angus young 2001-03-02 09:46:38 EST
no problem with wolverin for me
Comment 19 Derek Tattersall 2001-03-06 13:00:22 EST
Can't reproduce with kernel-2.4.2-0.1.20

Note You need to log in before you can comment on or make changes to this bug.