Bug 25988 - gray.mf refers to wrong mode
gray.mf refers to wrong mode
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-04 15:41 EST by Alan Shutko
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 19:53:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Shutko 2001-02-04 15:41:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.18 i686; en-US; 0.7) Gecko/20010111


gray.mf is is used whenever someone uses gftodvi (for example, when they're
working their way through the metafont book).  gray.mf by default loads
graycx.mf, which is a font for the cx.  If the user tries to xdvi the
results of gftodvi, it will display incorrectly and the user will get
errors of the form:

(/usr/share/texmf/fonts/source/public/misc/graycx.mf
! This file is for cx only.
<to be read again>
                   ;
l.4 ...>cx: errmessage "This file is for cx only";
                                                   fi

and cmr10 will be used instead of the gray font, yielding output which does
_not_ look right.

Reproducible: Always
Steps to Reproduce:
1. mf cmr10
2. gftodvi cmr10.2602gf
3. xdvi cmr10.dvi
	

Actual Results:  kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag
1+0/600 --dpi 600 gray
mktexpk: Running mf \mode:=ljfour; mag:=1+0/600; nonstopmode; input gray
This is METAFONT, Version 2.7182 (Web2C 7.3.1)
(/usr/share/texmf/fonts/source/public/misc/gray.mf
(/usr/share/texmf/fonts/source/public/misc/graycx.mf
! This file is for cx only.
<to be read again>
                   ;
l.4 ...>cx: errmessage "This file is for cx only";
                                                   fi
(/usr/share/texmf/fonts/source/public/misc/grayf.mf [0] [1] [2] [3] [4]
[5] [6] [7] [8] [9] [10] [11] [12] [13] [14] [15] [16] [17] [18] [19] [20]
[21] [22] [23] [24] [25] [26] [27] [28] [29] [30] [31] [32] [33] [34] [35]
[36] [37] [38] [39] [40] [41] [42] [43] [44] [45] [46] [47] [48] [49] [50]
[51] [52] [53] [54] [55] [56] [57] [58] [59] [60] [61] [62] [63] [64] [65]
[66] [67] [68] [69] [70] [71] [72] [73] [74] [75] [76] [77] [78] [79] [80]
[81] [82] [83] [84] [85] [86] [87] [88] [89] [90] [91] [92] [93] [94] [95]
[96] [97] [98] [99] [100] [101] [102] [103] [104] [105] [106] [107] [108]
[109] [110] [111] [112] [113] [114] [115] [116] [117] [118] [119] [120]
[121] [122] ) ) )
(see the transcript file for additional information)
Font metrics written on gray.tfm.
Output written on gray.600gf (123 characters, 13296 bytes).
Transcript written on gray.log.
mktexpk: `mf \mode:=ljfour; mag:=1+0/600; nonstopmode; input gray' failed.
kpathsea: Appending font creation commands to missfont.log.
xdvi.bin: can't find font gray; using cmr10 instead at 600 dpi.

Yields a picture of the font characters using text characters instead of
grayscale pattern.


Expected Results:  To see expected results,
cp `locate gray.mf` .
vi gray.mf
Change graycx to graylj
(Since the default xdvi mode is ljfour)
xdvi cmr10.dvi


The default xdvi mode is ljfour, but this can be changed in X resources.
The default mode for printers will differ.  I don't know of any way offhand
to set up gray.mf so that it will work for all printers and xdvi, but it
should at least work _somewhere_, and I'd suggest that somewhere would be xdvi.

This is an upstream bug, btw.

This bug has an easy workaround, but the workaround requires knowing about
metafont modes and where everything is set up, so the workaround may not be
readily apparent to most people, so I feel it should be fixed.
Comment 1 Alan Shutko 2001-02-04 16:13:20 EST
Incidently, this is the same for the black.mf file
Comment 2 Tim Waugh 2001-02-07 06:07:47 EST
Thanks.  Should be fixed in 1.0.7-13.

Note You need to log in before you can comment on or make changes to this bug.