Bug 26009 - requires information for perl modules not calculated correctly
requires information for perl modules not calculated correctly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-04 18:51 EST by Ganesh Sittampalam
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 13:07:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Makes find-requires.perl run perl.req on all .pm files, regardless of #! line (383 bytes, patch)
2001-02-05 11:20 EST, Ganesh Sittampalam
no flags Details | Diff

  None (edit)
Description Ganesh Sittampalam 2001-02-04 18:51:33 EST
The /usr/lib/rpm/find-requires.perl script decides whether to call 
perl.req for a particular file based on whether there is a "#!perl" line 
at the top of the file. This means that perl modules, which don't have 
this line as they are not designed to be executed directly, don't get 
their dependencies correctly calculated.
Comment 1 Jeff Johnson 2001-02-05 11:02:05 EST
rpm does not automagically detect perl module requirements using
find-requires.perl.

You will need to package your perl modules differently, enabling
find-requires.perl.
See any Red Hat CPAN package for an example.
Comment 2 Ganesh Sittampalam 2001-02-05 11:20:43 EST
Created attachment 9021 [details]
Makes find-requires.perl run perl.req on all .pm files, regardless of #! line
Comment 3 Ganesh Sittampalam 2001-02-05 11:22:23 EST
I'm using the Redhat cpanflute script to generate CPAN rpms, and it does enable 
find-requires.perl; the problem is that this script decides whether to call 
perl.req for a particular script by looking for #!/usr/bin/perl at the top. 

For example, the redhat powertools RPM perl-Convert-BER-1.26-6.i386.rpm fails 
to list perl(Math::BigInteger) and perl(bytes) as dependencies, despite the 
fact that these are not in the standard distribution.

I've uploaded a patch that works for me, but it does open up other problems 
because the perl package is not marked as providing things like Perl
(syscall.ph) which perl.req detects as a requirement for some packages.
Comment 4 Jeff Johnson 2001-02-21 13:07:19 EST
Changing component
Comment 5 Jeff Johnson 2002-02-05 12:57:36 EST
I believe this problem is fixed in rpm-4.0.4 /usr/lib/rpm/perl.req.
Please reopen if I'm wrong.

Note You need to log in before you can comment on or make changes to this bug.