Bug 26013 - sawfish complains about lack of XINERAMA support
sawfish complains about lack of XINERAMA support
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
: 26448 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-04 19:03 EST by Jay Berkenbilt
Modified: 2007-04-18 12:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 11:23:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2001-02-04 19:03:38 EST
Sawfish as installed in Fisher complains about lack of XINERAMA support:

Xlib:  extension "XINERAMA" missing on display ":0.0".

I suppose this has to do with XFree86 4.x.  sawfish still works fine, but
this warning message is (very slightly) annoying and, more importantly,
could be an indication of something not being built or installed properly. 
I don't know.
Comment 1 Havoc Pennington 2001-02-05 16:00:57 EST
Unless you have two monitors, then it's normal for your display not to support
Xinerama. Sawfish is trying to use the extension without calling
XineramaQueryExtension() first to be sure it exists. Not really hurting
anything, except that it causes the error spew.
Comment 2 Jay Berkenbilt 2001-02-05 18:29:14 EST
I've forwarded this information to the sawmill@aarg.net mailing list.
Comment 3 Jay Berkenbilt 2001-02-05 19:21:01 EST
Sorry for the wasted bandwidth.... I mean sawfish@lists.eazel.com, not
sawmill@aarg.net....
Comment 4 Need Real Name 2001-02-07 17:34:23 EST
I've fixed this problem now
Comment 5 Alexei Podtelezhnikov 2001-02-09 16:18:15 EST
*** Bug 26448 has been marked as a duplicate of this bug. ***
Comment 6 Jay Berkenbilt 2001-02-24 00:58:44 EST
Although this bug has been fixed in the latest sawfish, it still appears in
Wolverine.  This and other bugs have been corrected in 0.37.3.
Comment 7 Havoc Pennington 2001-02-24 01:18:18 EST
Upgrading to a new version at this point in the release cycle would make me
quite nervous, unless John says 0.37 is bugfixes only and Preston thinks it's a
good idea.
Comment 8 Need Real Name 2001-02-24 02:15:57 EST
0.36 -> 0.37.3 was mostly bug fixes, but a few minor features also snuck in

In case you just want to patch your version to fix the Xinerama problem, the
patch is here:

http://cvs.gnome.org/bonsai/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=functions.c&root=/cvs/gnome&subdir=sawfish/src&command=DIFF_FRAMESET&rev1=1.85&rev2=1.86
Comment 9 Jay Berkenbilt 2001-03-22 01:16:35 EST
I'm wondering why this bug has not gotten any attention for a long time.  It's
the only bug I reported against Fisher or Wolverine that hasn't been long-since
resolved.  Maybe it's because I marked at as low priority?  Anyway, since John
provided a simple patch to fix this specific problem and since there have been a
number of sawfish updates via up2date since wolverine has been out, is there any
chance this simple problem could be fixed before 7.1?  This is one of these
fixes that is so low cost and low risk that it seems silly (to me anyway) not to
fix it.
Comment 10 Jay Berkenbilt 2001-04-22 00:39:57 EDT
Obviously this didn't make it into 7.1, but no matter -- I'm sure the next
release will include an updated sawfish which will include this fix (as jsh
fixed it in the real version...)  Why doesn't someone just close this out --
maybe marking it deferred?
Comment 11 Havoc Pennington 2001-04-22 02:40:55 EDT
Normally we would keep a bug open until the fix is actually in the devel tree.
I actually had this patch applied to the SRPM on my local hard drive but 
broke my arm before I could put it in the release - such is life.
Comment 12 Jay Berkenbilt 2001-04-23 11:23:00 EDT
Ouch.  I hope your arm is recovering well.  My solution to this problem is to
redirect stdout and stderr of my window manager to ~/tmp/.wm.out.  Most people
wouldn't see this because their output would go to .xsession-errors, but my
startup environment doesn't work this way.  Thanks for the reply.
Comment 13 Havoc Pennington 2001-07-12 15:30:29 EDT
Fixed now

Note You need to log in before you can comment on or make changes to this bug.