Bug 260181 - "need ACPI support in kernel." message during boot
"need ACPI support in kernel." message during boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
8
All All
medium Severity low
: ---
: ---
Assigned To: Zdenek Prikryl
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 09:33 EDT by Tom London
Modified: 2008-04-04 09:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 09:51:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom London 2007-08-28 09:33:00 EDT
Description of problem:
S44acpid checks for kernel support via:
        # Check for kernel support
        if [ ! -f /proc/acpi/event ]; then
                echo "$0: need ACPI support in kernel."
                exit 1
        fi

But running kernel-2.6.23-0.139.rc3.git10.fc8, 'ls -l /proc/acpi' is:
[tbl@localhost ~]$ ls -l /proc/acpi
total 0
dr-xr-xr-x 3 root root 0 2007-08-28 06:23 ac_adapter
dr-xr-xr-x 3 root root 0 2007-08-28 06:23 battery
dr-xr-xr-x 5 root root 0 2007-08-28 06:23 button
-r-------- 1 root root 0 2007-08-28 06:23 dsdt
dr-xr-xr-x 3 root root 0 2007-08-28 06:23 embedded_controller
-r-------- 1 root root 0 2007-08-28 06:23 fadt
dr-xr-xr-x 2 root root 0 2007-08-28 06:23 fan
dr-xr-xr-x 2 root root 0 2007-08-28 06:23 ibm
-r--r--r-- 1 root root 0 2007-08-28 06:23 info
dr-xr-xr-x 3 root root 0 2007-08-28 06:23 power_resource
dr-xr-xr-x 4 root root 0 2007-08-28 06:23 processor
dr-xr-xr-x 4 root root 0 2007-08-28 06:23 thermal_zone
dr-xr-xr-x 4 root root 0 2007-08-28 06:23 video
-rw-r--r-- 1 root root 0 2007-08-28 06:23 wakeup
[tbl@localhost ~]$

So acpid is not started.


Version-Release number of selected component (if applicable):
acpid-1.0.6-1.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zdenek Prikryl 2007-08-29 03:45:13 EDT
This is not bug in acpid, but this is caused by disabled option kernel.

In 2.6.23 and newer kernel is option ACPI_PROC_EVENT. By Default is this option
disabled (in kernel-2.6.23-0.139.rc3.git10.fc8 is disabled), so file
/proc/acpi/event will not be created. Acpid and probably other user-space
daemons depend on this file, so option ACPI_PROC_EVENT should be set to "y".

Zdenek
Comment 2 Tom London 2007-09-12 15:20:09 EDT
Recent kernels appear to be defining CONFIG_ACPI_PROC_EVENT, so this issue has
'gone away'.

Close this, or keep it open to track when it gets disabled for good?
Comment 3 Dave Jones 2007-09-14 13:08:01 EDT
CONFIG_ACPI_PROC_EVENT will be around for a while, but upstream intends to
remove this functionality completely at the end of the year.  We should make
sure that acpid can get this info by other means before then so that when we
push a rebased kernel as an update for F8, it'll "just work".
Comment 4 Bug Zapper 2008-04-04 09:41:49 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 5 Tom London 2008-04-04 09:51:44 EDT
I was leaving this open as a tracker for comment #3 from Dave Jones.

However, this can be closed (and reopened if needed in the future).

Note You need to log in before you can comment on or make changes to this bug.