Bug 260301 - kernel: kernel BUG at include/asm/spinlock.h:109!
kernel: kernel BUG at include/asm/spinlock.h:109!
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Prarit Bhargava
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 10:28 EDT by V Adcock
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 10:19:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description V Adcock 2007-08-28 10:28:57 EDT
Description of problem: System panics and locks up had to do a hard reboot
Aug 22 20:44:57 lmm21171 kernel: ------------[ cut here ]------------
           

Aug 22 20:44:57 lmm21171 kernel: kernel BUG at 
include/asm/spinlock.h:109!      

Aug 22 20:44:57 lmm21171 kernel: invalid operand: 0000 
[#1]                     

Aug 22 20:44:57 lmm21171 kernel: 
SMP                                            

Aug 22 20:44:57 lmm21171 kernel: Modules linked in: rcon(U) nls_utf8 
parport_pc 

lp parport autofs4 i2c_dev i2c_core sunrpc button battery ac md5 joydev ipv6 
uhc

i_hcd ehci_hcd tg3 st dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod aacraid 
aic7

9xx sd_mod 
scsi_mod                                                             

Aug 22 20:44:57 lmm21171 kernel: CPU:    
0                                      

Aug 22 20:44:57 lmm21171 kernel: EIP:    0060:[<c02d34e0>]    Tainted: P      
VL

I                                                                              
 

Aug 22 20:44:57 lmm21171 kernel: EFLAGS: 00010002   (2.6.9-
42.ELsmp)            

Aug 22 20:44:57 lmm21171 kernel: EIP is at 
_spin_unlock_irqrestore+0x1f/0x2d    

Aug 22 20:44:57 lmm21171 kernel: eax: 00000001   ebx: 00000286   ecx: 
f8a07da4  

 edx: 
00000201                                                                  

Aug 22 20:44:57 lmm21171 kernel: esi: f8a07da4   edi: ef115000   ebp: 
e2f79f10  

 esp: 
e2f79ee0                                                                  

Aug 22 20:44:57 lmm21171 kernel: ds: 007b   es: 007b   ss: 
0068                 

Aug 22 20:44:57 lmm21171 kernel: Process rundml (pid: 29776, 
threadinfo=e2f79000

 
task=d557aeb0)                                                                 

Aug 22 20:44:57 lmm21171 kernel: Stack: 00000286 c02d2af7 00000000 d557aeb0 
c011

e794 00100100 00200200 
00000320                                                 

Aug 22 20:44:57 lmm21171 kernel:        f89ff629 f8a07da4 e2f79000 e2f79000 
e2f7

9fac f89ff036 00000000 
00000000                                                 

Aug 22 20:44:57 lmm21171 kernel:        17be9025 f89ff686 00357787 f8a02000 
f5f9

f6e0 00000000 00357787 
00000001                                                 

Aug 22 20:44:57 lmm21171 kernel: Call 
Trace:                                    

Aug 22 20:44:57 lmm21171 kernel:  [<c02d2af7>] 
interruptible_sleep_on+0xbf/0xc6 

Aug 22 20:44:57 lmm21171 kernel:  [<c011e794>] 
default_wake_function+0x0/0xc    

Aug 22 20:44:57 lmm21171 kernel:  [<f89ff629>] DelayWakeup+0x0/0xc 
[rcon]       

Aug 22 20:44:57 lmm21171 kernel:  [<f89ff036>] dv_linux_sleep+0x36/0x5d 
[rcon]  

Aug 22 20:44:57 lmm21171 kernel:  [<f89ff686>] small_delay+0x51/0x5b 
[rcon]     

Aug 22 20:44:57 lmm21171 kernel:  [<f8a02000>] read_cannon+0x143/0x46f 
[rcon]   

Aug 22 20:44:57 lmm21171 kernel:  [<c01fcf4d>] 
tty_read+0x0/0x127               

Aug 22 20:44:57 lmm21171 kernel:  [<f8a02417>] snoop_read+0xeb/0x1bd 
[rcon]     

Aug 22 20:44:57 lmm21171 kernel:  [<c015af11>] 
vfs_read+0xb6/0xe2               

Aug 22 20:44:57 lmm21171 kernel:  [<c015b124>] 
sys_read+0x3c/0x62               

Aug 22 20:44:57 lmm21171 kernel:  [<c02d4703>] 
syscall_call+0x7/0xb             

Aug 22 20:44:57 lmm21171 kernel: Code: 00 00 00 01 74 05 e8 98 e8 ff ff c3 53 
89

 c1 89 d3 81 78 04 ad 4e ad de b2 01 74 08 0f 0b 6c 00 0c 60 2e c0 0f b6 01 84 
c

0 7e 08 <0f> 0b 6d 00 0c 60 2e c0 86 11 53 9d 5b c3 81 78 04 ad 4e ad 
de        

Aug 22 20:44:57 lmm21171 kernel:  <0>Fatal exception: panic in 5 seconds     


Version-Release number of selected component (if applicable):
[root@lmm21171 ~]# uname -
a                                                     
Linux lmm21171 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:27:17 EDT 2006 i686 i686 
i386
 
GNU/Linux                                                                      
[root@lmm21171 ~]# cat /etc/redhat-
release                                      
Red Hat Enterprise Linux ES release 4 (Nahant Update 
4)                         


How reproducible:unknown


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Prarit Bhargava 2007-09-04 09:54:58 EDT
v.adcock,

Could you provide the system arch, # of processors, etc.?

Does this happen 100% of the time?

P.
Comment 2 V Adcock 2007-09-11 15:43:32 EDT
IBM 3500 Dual Processor 8GB RAM. 

Has happened twice. 
Comment 3 Prarit Bhargava 2007-09-17 09:53:21 EDT
Hi v.adcock,

What were you doing on the system when this happens?  Was the system under any
type of load, etc?

Could you attach a dmesg output to this BZ?

Thanks :)

P.
Comment 4 Prarit Bhargava 2007-09-17 10:07:02 EDT
Cleaned up ...

------------[ cut here ]------------
BUG at include/asm/spinlock.h:109!
invalid operand: 0000[#1] SMP
Modules linked in: rcon(U) nls_utf8 parport_pc lp parport autofs4 i2c_dev
i2c_core sunrpc button battery ac md5 joydev ipv6 uhc i_hcd ehci_hcd tg3 st
dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod aacraid aic7 9xx sd_mod scsi_mod
CPU:    0
EIP:    0060:[<c02d34e0>]    Tainted: PVLI
EFLAGS: 00010002   (2.6.9-42.ELsmp)
EIP is at _spin_unlock_irqrestore+0x1f/0x2d
eax: 00000001   ebx: 00000286   ecx: f8a07da4   edx: 00000201
esi: f8a07da4   edi: ef115000   ebp: e2f79f10   esp: e2f79ee0
ds: 007b   es: 007b   ss: 0068
Process rundml (pid: 29776, threadinfo=e2f79000 task=d557aeb0)
Stack: 00000286 c02d2af7 00000000 d557aeb0 c011e794 00100100 00200200 00000320
       f89ff629 f8a07da4 e2f79000 e2f79000 e2f79fac f89ff036 00000000 00000000
       17be9025 f89ff686 00357787 f8a02000 f5f9f6e0 00000000 00357787 00000001
Call Trace:
 [<c02d2af7>] interruptible_sleep_on+0xbf/0xc6
 [<c011e794>] default_wake_function+0x0/0xc
 [<f89ff629>] DelayWakeup+0x0/0xc [rcon]
 [<f89ff036>] dv_linux_sleep+0x36/0x5d [rcon]
 [<f89ff686>] small_delay+0x51/0x5b [rcon]
 [<f8a02000>] read_cannon+0x143/0x46f [rcon]
 [<c01fcf4d>] tty_read+0x0/0x127
 [<f8a02417>] snoop_read+0xeb/0x1bd [rcon]
 [<c015af11>] vfs_read+0xb6/0xe2
 [<c015b124>] sys_read+0x3c/0x62
 [<c02d4703>] syscall_call+0x7/0xb
Code: 00 00 00 01 74 05 e8 98 e8 ff ff c3 53 89
 c1 89 d3 81 78 04 ad 4e ad de b2 01 74 08 0f 0b 6c 00 0c 60 2e c0 0f b6 01 84 c
0 7e 08 <0f> 0b 6d 00 0c 60 2e c0 86 11 53 9d 5b c3 81 78 04 ad 4e ad de
<0>Fatal exception: panic in 5 seconds
Comment 5 Prarit Bhargava 2007-09-17 10:19:48 EDT
v.adcock,

After quickly looking at your oops it looks like 

a) you have a proprietary module loaded, and
b) that module is responsible for the panic.

RH does not debug vendor's proprietary modules.

Closing as NOTABUG.

P.

Note You need to log in before you can comment on or make changes to this bug.