Bug 26060 - xircom_tulip_cb doesn't work
xircom_tulip_cb doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Florence Gold
:
: 26130 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-05 03:39 EST by Magnus Heino
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 22:10:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Magnus Heino 2001-02-05 03:39:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


The xircom_tulip_cb driver included in fisher doesn't work. The adapter is 
detected, but that is all.

Reproducible: Always
Steps to Reproduce:
1. Install fisher with a Xircom pcmcia ethernet card.
	

Actual Results:  cs: cb_alloc(bus 2): vendor 0x115d, device 0x0003
  got res[1800:187f] for resource 0 of PCI device 115d:0003
  got res[10800000:108007ff] for resource 1 of PCI device 115d:0003
  got res[10800800:10800fff] for resource 2 of PCI device 115d:0003
  got res[10400000:10403fff] for resource 6 of PCI device 115d:0003
PCI: Enabling device 02:00.0 (0000 -> 0003)
  got res[1880:1887] for resource 0 of PCI device 115d:0103
  got res[10801000:108017ff] for resource 1 of PCI device 115d:0103
  got res[10801800:10801fff] for resource 2 of PCI device 115d:0103
  got res[10404000:10407fff] for resource 6 of PCI device 115d:0103
PCI: Enabling device 02:00.1 (0000 -> 0003)                         

tulip_attach(02:00.0)
PCI: Setting latency timer of device 02:00.0 to 64
xircom_tulip_cb.c:v0.91 4/14/99 becker@cesdis.gsfc.nasa.gov (modified by 
danilo@cs.uni-magdeburg.de for XIRCOM CBE, fixed by Doug Ledford)
eth1: Xircom Cardbus Adapter (DEC 21143 compatible mode) rev 3 at 0x1800, 
00:10:A4:A5:3D:B8, IRQ 11.
eth1:  MII transceiver #0 config 3100 status 7809 advertising 01e1.
spurious 8259A interrupt: IRQ7.
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0800-0x08ff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x378-0x37f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.   

In the version included with fisher, and the 2.4.1 kernel, nothing at all 
works. No packets what so ever gets through.

Using linux-2.4.1-ac2 I receive broadcast packages, but nothing else. I 
can see other machines broadcast messages, and receive broadcast messages 
sent out by me, i.e. dhcp works. But I can't do anything else, like ping...
Comment 1 Arjan van de Ven 2001-02-05 04:29:45 EST
We know that this card does not work. I can see similar behavior, where 
the card I have does receive packets but refuses to send any packets. 
There is no solution yet, but we're working on it.
Comment 2 Bill Nottingham 2001-02-05 17:03:33 EST
'ifconfig eth0 arp' has been known to fix it.
Comment 3 Bill Nottingham 2001-02-05 17:05:22 EST
*** Bug 26130 has been marked as a duplicate of this bug. ***
Comment 4 Glen Foster 2001-02-05 17:35:17 EST
We (Red Hat) should really try to fix this before next release.
Comment 5 David Sainty 2001-02-12 14:01:15 EST
Same problem. I volunteer to test any patches.


David S..
Comment 6 Need Real Name 2001-02-15 10:49:01 EST
I have the same problem (Dell Latitude CSx, Xircom card) using dhcp to get my address (and failing ofcourse).  ifconfig eth0 arp does not always fix it, don't know why.
Comment 7 LENHOF 2001-02-27 07:31:03 EST
I have had the same problem but the known problem on a Dell Latitude with a
xircom RBEM56G-100

ifconfig eth0 promisc
OR
ifconfig eth0 allmulti

could make it work

Comment 8 LENHOF 2001-02-27 07:33:54 EST
Sorry for not ending my sentence...
I just would like to say that I found this tip on pcmcia-cs on sourceforge.net
under known bug

Regards
Jean-Yves LENHOF
lenh_jea@caramail.com
lenhof@edf.fr
Comment 9 Michael K. Johnson 2001-02-28 22:10:06 EST
A re-written driver is in our kernels, and will be made available
in rawhide in our next release to rawhide, version 2.4.2-0.1.16 or
later.
Comment 10 Arjan van de Ven 2001-03-07 06:33:34 EST
The xircom_cb driver in latest kernels seem to work for everyone so far.
If it doesn't work for you, please reopen this bug, or file a new one.
Comment 11 David Sainty 2001-03-10 16:14:37 EST
One note about this... Although the card now seems to work really well upon
insertion, DHCP is successful, there are no reported errorts, etc, the speed
seems _very_ slow. Considering this Xircom Tulip is supposed to do 100Mbit FDX....

Here are results from three tests conducted simultaneously, to receive rawhide
RPMS off a server (e100 100FDX, RHL7 2.2.17 errata kernel) via a Cisco 4006
10/100 FDX capable switch using ncftp on the clients:

Machine               Card                    Av. Reported Transfer Speed
-------------------------------------------------------------------------
1. Latitude LS500        Xircom Tulip 10/100 CB card               185kB/sec
2. Latitude CPx650       3Com 3c574 10/100 PC (16b) card           800kB/sec
3. Dual PIII Xeon        3Com on-board 10/100 PCI                   10MB/sec

Considering this is supposed to be a CardBus 100Mbit FDX connection, the
performance is 2% of what it should be.  (Kernel used for 1. is 2.4.2-0.1.22,
for 2. and 3. is 2.4.2-0.1.20)

Also worth looking at may be the port statistics for 1. and 2 on the cisco:

---------------------

From 1.... (the Xircom tulip CB card)

RH-SURREY-SW0> (enable) show port 2/37
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
 2/37                    connected  1          normal   full   100 10/100BaseTX


Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
----- -------- --------- ------------- -------- -------- -------- -------
 2/37 disabled  shutdown             0        0        1 disabled      92

Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
----- -------- ----------------- -------- ----------------- ------------------
 2/37        0                 -        -                 -        -         -

Port  Status     Channel              Admin Ch
                 Mode                 Group Id
----- ---------- -------------------- ----- -----
 2/37 connected  auto silent             24     0

Port  Align-Err  FCS-Err    Xmit-Err   Rcv-Err    UnderSize
----- ---------- ---------- ---------- ---------- ---------
 2/37          -       4573          0       9146         0

Port  Single-Col Multi-Coll Late-Coll  Excess-Col Carri-Sen Runts     Giants
----- ---------- ---------- ---------- ---------- --------- --------- ---------
 2/37          0          0          0          0         0      4573         0
        
Last-Time-Cleared
--------------------------
Sat Mar 10 2001, 12:43:50

--------------

From 2... (3Com PC card)

RH-SURREY-SW0> (enable) show port 2/33
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
 2/33                    connected  1          normal   full   100 10/100BaseTX


Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
----- -------- --------- ------------- -------- -------- -------- -------
 2/33 disabled  shutdown             0        0        1 disabled      88

Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
----- -------- ----------------- -------- ----------------- ------------------
 2/33        0                 -        -                 -        -         -

Port  Status     Channel              Admin Ch
                 Mode                 Group Id
----- ---------- -------------------- ----- -----
 2/33 connected  auto silent             23     0

Port  Align-Err  FCS-Err    Xmit-Err   Rcv-Err    UnderSize
----- ---------- ---------- ---------- ---------- ---------
 2/33          -         17          0        933       900

Port  Single-Col Multi-Coll Late-Coll  Excess-Col Carri-Sen Runts     Giants
----- ---------- ---------- ---------- ---------- --------- --------- ---------
 2/33          0          0          0          0         0        16         0
        
Last-Time-Cleared
--------------------------
Sat Mar 10 2001, 12:43:50

-------------------------

These two sets of port statistics were recorded at the same time, and the packet
counts are over the same time period. Note the particularly high number of FCS
errors, Rcv Errors and Runts on the port, even though there are no errors,
dropped, overrun, etc when you do an ifconfig?! Is this a driver problem, or
something else we're seeing?

I have not re-opened this bug, since it may be a seperate issue we're seeing...


DS..

Comment 12 Arjan van de Ven 2001-03-10 16:56:02 EST
1) If you want speed, buy a decent card :)

2) ifconfig doesn't report most errors as there seems to be no reliable way of
    detecting them.

As the card seems to generate errors, I'll see if I can produce such statistics
and then improve

Note You need to log in before you can comment on or make changes to this bug.