Bug 260681 - puplet doesn't start in fedora devel
puplet doesn't start in fedora devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 12:07 EDT by Mark
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 13:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2007-08-28 12:07:07 EDT
Description of problem:
Puplet should be started at default. the lines are all correct but puplet has
some errors which prevent it from starting up.

Version-Release number of selected component (if applicable):


How reproducible:
Install the Fedora 8 development version and update to the latest stuff

Steps to Reproduce:
1. Install the Fedora 8 development version and update to the latest stuff
2. When there are new updates you won't see a update notification on your desktop
3.
  
Actual results:
Puplet doesn't start

Expected results:
Puplet should start

Additional info:
When starting puplet in a console i see this:
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 210, in
maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/bin/puplet", line 279, in updates_avail_handler
    self.trayicon.set_tooltip(num)
TypeError: GtkStatusIcon.set_tooltip() argument 1 must be string or None, not int
Traceback (most recent call last):
  File "/usr/bin/puplet", line 384, in <module>
    main()
  File "/usr/bin/puplet", line 381, in main
    p.run()
  File "/usr/bin/puplet", line 371, in run
    gtk.main()
KeyboardInterrupt

Note: i filled it under "yum" because i couldn't find "puplet" in the Component
box while filling in the bug report.
Comment 1 Jeremy Katz 2007-08-28 13:12:38 EDT
'rpm -qf /usr/bin/puplet' gives you pirut, which is the right thing.  And this
is fixed up in CVS, new build will be going out later today with the fix.

Note You need to log in before you can comment on or make changes to this bug.