Bug 26070 - xfs segfault
Summary: xfs segfault
Status: CLOSED DUPLICATE of bug 22538
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-05 12:46 UTC by Tim Waugh
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-05 22:58:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (86.64 KB, text/plain)
2001-02-05 12:46 UTC, Tim Waugh
no flags Details
ltrace output (1.03 MB, text/plain)
2001-02-05 12:48 UTC, Tim Waugh
no flags Details
Rabbit ear font (26.82 KB, application/octet-stream)
2001-02-05 12:49 UTC, Tim Waugh
no flags Details
stack trace (3.48 KB, text/plain)
2001-02-05 18:36 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2001-02-05 12:46:05 UTC
I can make xfs crash.

1. Fire up GIMP.
2. New image.
3. Text tool, click in image.
4. Type 'FBI' in sampler.
5. Select 28 point size.
6. Select 'Rabbitears' font (a free font; I'll attach it).
7. Boom.

Comment 1 Tim Waugh 2001-02-05 12:46:31 UTC
Created attachment 8999 [details]
strace output

Comment 2 Tim Waugh 2001-02-05 12:48:14 UTC
Created attachment 9000 [details]
ltrace output

Comment 3 Tim Waugh 2001-02-05 12:49:20 UTC
Created attachment 9001 [details]
Rabbit ear font

Comment 4 Tim Waugh 2001-02-05 18:36:32 UTC
Created attachment 9059 [details]
stack trace

Comment 5 Glen Foster 2001-02-05 22:58:21 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 6 Bernhard Rosenkraenzer 2001-02-06 18:37:47 UTC
This happens with any TrueType font, using any program to access it in any way.
Btw: Are you sure the font is really free? If so, we might want to add it to 
the ttfonts package.



*** This bug has been marked as a duplicate of 22538 ***


Note You need to log in before you can comment on or make changes to this bug.