Bug 260981 - virt-install: incorrect domain XML (<source file=''/>) prevents domain from rebooting after install
virt-install: incorrect domain XML (<source file=''/>) prevents domain from r...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-28 13:01 EDT by Richard W.M. Jones
Modified: 2008-01-22 10:32 EST (History)
0 users

See Also:
Fixed In Version: 0.300.2-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:32:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2007-08-28 13:01:09 EDT
Description of problem:

After an install of a fullvirt 32-bit FreeBSD 6.2 guest on
Fedora Rawhide from an ISO image, the first reboot fails
with an error message about missing drive [I don't have the
original error message and it doesn't seem to have been saved
anywhere].

After investigation, I did 'virsh dumpxml freebsd32fv' and found
this section:

   <disk type='file' device='cdrom'>
     <driver name='file'/>
     <source file=''/>
     <target dev='hdc'/>
     <readonly/>
   </disk>

This seems to be causing the domain to fail to reboot.  Removing
just the <source file=''/> element is sufficient to make the domain
bootable again.

Version-Release number of selected component (if applicable):

kernel-xen-2.6.21-2931.fc8
xen-3.1.0-2.fc8
libvirt-0.3.2-2.fc8
libvirt-python-0.3.2-2.fc8
python-virtinst-0.200.0-3.fc8
virt-manager-0.4.0-3.fc8

How reproducible:

(Only tried it once).

Steps to Reproduce:
1. Download 6.2-RELEASE-i386-bootonly.iso from freebsd.org
2. Install FreeBSD from this ISO using virt-manager.
3. Reboot at the end of the install.
  
Actual results:

Domain fails to reboot.

Expected results:

Domain should reboot.

Additional info:
Comment 1 Daniel Berrange 2007-08-28 23:04:29 EDT
Applied a fix upstream:

changeset:   261:3ea0c5d79b6a
tag:         tip
user:        "Daniel P. Berrange <berrange@redhat.com>"
date:        Tue Aug 28 23:02:32 2007 -0400
summary:     Fixed bug 260981 with empty cdrom source path


Will incorporate in next update for Fedora.
Comment 2 Fedora Update System 2008-01-11 17:27:57 EST
python-virtinst-0.300.2-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'
Comment 3 Fedora Update System 2008-01-22 10:32:26 EST
python-virtinst-0.300.2-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.