Bug 26113 - less can't properly display Japanese doc
Summary: less can't properly display Japanese doc
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: less   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Aaron Brown
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-05 17:38 UTC by Bill Huang
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 18:56:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Huang 2001-02-05 17:38:04 UTC
When less a Japanese text file,letters get scrembled.
so, if man man ,Japanese cant displayed properly

Comment 1 Bill Huang 2001-02-05 18:04:13 UTC
if JLESSCHARSET=japanese is exported,less can display Japanese properly.
So,is it a problem of anaconda?


Comment 2 Karsten Hopp 2001-02-05 18:25:30 UTC
Does this problem still exist with the newest less rpm in dist/7.1 ?
 (rpm-358-14.i386.rpm)

Comment 3 Nakai 2001-02-05 18:45:00 UTC
This is because anaconda sets LANG=ja_JP.eucjp at install,
and bashrc set JLESSCHARSET=japanese only when LANG=ja or LANG=ja_JP.eucjp.

When I set JLESSCHARSE=japanese manually, it works.

It is an anaconda problem, so it's not less problem.
(msw@redhat.com is better to assign this bug)


Comment 4 Glen Foster 2001-02-05 22:58:03 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 5 Matt Wilson 2001-02-05 23:05:11 UTC
LANG=ja_JP.eucjp less /mnt/redhat/comps/dist/7.1/READMES/i386/RELEASE-NOTES.ja
does not work
LANG=en_US less /mnt/redhat/comps/dist/7.1/READMES/i386/RELEASE-NOTES.ja *works*
Why is this?


Comment 6 Matt Wilson 2001-02-05 23:11:30 UTC
also, ja_JP.eucJP works, so there is a bug in the less patch.


Comment 7 Matt Wilson 2001-02-05 23:16:25 UTC
--- less-358+iso247-20001210.diff~      Sun Dec 10 02:53:55 2000
+++ less-358+iso247-20001210.diff       Mon Feb  5 17:20:04 2001
@@ -355,7 +355,7 @@
 +              name = getenv("LANG");
 +      for (p = charlocales; name && p->name != NULL; p++)
 +      {
-+              if (strcmp(name, p->name) == 0)
++              if (strcasecmp(name, p->name) == 0)
 +              {
 +                      (void) icharset(p->charset);
 +                      return;


rebuilding...


Comment 8 Matt Wilson 2001-02-07 18:56:20 UTC
fixed.


Comment 9 Bill Huang 2001-02-07 19:52:15 UTC
Fixed.less can display Japanese text file properly.


Note You need to log in before you can comment on or make changes to this bug.