Bug 26131 - No 3D acceleration with Voodoo3 card
No 3D acceleration with Voodoo3 card
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-05 13:43 EST by Anthony Rumble
Modified: 2007-04-18 12:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 14:47:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Startup Log fragment (2.12 KB, text/plain)
2001-02-05 13:48 EST, Anthony Rumble
no flags Details

  None (edit)
Description Anthony Rumble 2001-02-05 13:43:36 EST
Voodoo3 cards seem to not have 3D hardware acceleration
with XFree 4.0.2. Falls back to software accel.
Comment 1 Anthony Rumble 2001-02-05 13:46:42 EST
Relevant email information :-

tdfx.o kernel mod loaded
right bits enabled in the XFree86-4 file

However there seems to be a few inconsistancies as per the DRI Howto..

Running glxinfo I get :-
...
OpenGL vendor string: VA Linux Systems, Inc.
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 Mesa 3.4
...

Which as per the DRI User guide, means theres no hardware acceleration
happening..

Also theres no /usr/X11R6/lib/modules/dri/tdfx_dri.so

and theres no non-Mesa libGL.so (Which the user guide also mentions).

It states glxinfo should say something like this ..

...
OpenGL vendor string: VA Linux Systems, Inc.
OpenGL renderer string: Mesa DRI Voodoo3 20000224
OpenGL version string: 1.2 Mesa 3.4
...

Comment 2 Anthony Rumble 2001-02-05 13:48:41 EST
Created attachment 9060 [details]
Startup Log fragment
Comment 3 Kees Cook 2001-02-05 17:34:26 EST
I am seeing this problem as well.  I think it has to do entirely with the
missing tdfx_dri.so driver.
Comment 4 Glen Foster 2001-02-05 17:35:09 EST
We (Red Hat) should really try to fix this before next release.
Comment 5 Joseph Fannin 2001-02-05 21:21:20 EST
     I agree with cook -- the problem is the missing 3dfx dri driver in the
XFree RPM:

[root@gibraltar /root]# export LIBGL_DEBUG=verbose
[root@gibraltar /root]# glxinfo
libGL: trying /usr/X11R6/lib/modules/dri/tdfx_dri.so
libGL error: dlopen failed: /usr/X11R6/lib/modules/dri/tdfx_dri.so: cannot open
shared object file: No such file or directory
libGL: trying /usr/X11R6/lib/modules/dri/tdfx_dri.so
libGL error: dlopen failed: /usr/X11R6/lib/modules/dri/tdfx_dri.so: cannot open
shared object file: No such file or directory

    As a long shot, I tried the XFree86-glide-module RPM from mandrake cooker,
which includes the module.  The errors went away, but it didn't work.

    If this can't be fixed the Release Notes claiming 3d support for 3dfx should
be changed.
Comment 6 Harald Hoyer 2001-02-06 12:10:07 EST

*** This bug has been marked as a duplicate of 25890 ***
Comment 7 Kees Cook 2001-02-06 13:07:07 EST
Why can't I view bug 25890?

I found the problem with the build, it's an issue with the SPEC file:

--- XFree86.spec        Tue Feb  6 11:11:31 2001
+++ XFree86.spec.fixed  Tue Feb  6 11:10:56 2001
@@ -443,7 +443,7 @@

 %if %{BuildTdfx}
   %ifarch %{ix86} alpha ia64
-       #define HasGlide3 YES
+#define HasGlide3 YES
   %endif
 %endif



You can't have "tabs" leading a "#define" line for Imake.  As a result, this
define never got defined.
Just take out the tab, and rebuild the rpm (I'm doing this now....)
Comment 8 Mike A. Harris 2001-02-06 14:29:09 EST
Resolved in my latest build.  Will appear in Rawhide sometime soon.
Comment 9 Joseph Fannin 2001-02-12 03:34:21 EST
I'm having difficulty finding an updated package on ftp.redhat.com/pub/rawhide
.  Am I looking in the wrong place?
Comment 10 Bill Nottingham 2001-02-19 14:55:10 EST
It's not there in -9. Reopening.
Comment 11 Bill Nottingham 2001-02-28 15:06:05 EST
It is there in -10  and -11. Reclosing.
Comment 12 Joseph Fannin 2001-03-01 02:26:04 EST
    Works for me on wolverine with the XFree86-4.0.2-9.2 package.  Excellent!

Note You need to log in before you can comment on or make changes to this bug.