Bug 26133 - cdrecord reports invalid lun and/or cannot open scsi driver
Summary: cdrecord reports invalid lun and/or cannot open scsi driver
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cdrecord (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-05 19:01 UTC by Robert M. Riches Jr.
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 19:14:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/cdrecord.conf (834 bytes, text/plain)
2001-02-05 19:02 UTC, Robert M. Riches Jr.
no flags Details
output of lsmod (241 bytes, text/plain)
2001-02-05 19:03 UTC, Robert M. Riches Jr.
no flags Details
output of cdrecord -scanbus (620 bytes, text/plain)
2001-02-05 19:04 UTC, Robert M. Riches Jr.
no flags Details
output of cdrecord -checkdrive (278 bytes, text/plain)
2001-02-05 19:05 UTC, Robert M. Riches Jr.
no flags Details
context diff between non-working (.~2~) and working (plain) config file. (470 bytes, text/plain)
2001-02-08 19:14 UTC, Robert M. Riches Jr.
no flags Details

Description Robert M. Riches Jr. 2001-02-05 19:01:48 UTC
cdrecord (does not work and) gives two error messages, one about an
invalid lun specifier, and one that it cannot open SCSI driver.

Hardware:  API UP2000 (supported according to my RH7 box). Yamaha
SCSI CRW8424S writer drive connected to the single-ended (Adaptec)
motherboard connector.

Software:  RH7, supplied 2.2.17-4 kernel, updated packages as of this
morning.

History:  The writer was working great with RH6.1 and standard packages.

Current:  The drive works fine as a CD reader--I can mount an installation
CD, mount it, and look through the contents.  The 'sg' driver seems to be
in place, according to lsmod, and working, as I can successfully use a
SCSI scanner (from a NCR/Symbios adapter card--no change from when
cdrecord worked on 6.1).  When I do 'cdrecord -scanbus', it gives me what
appears to be the correct bus,id,lun tuple (the same as I used with RH6.1).
When I do 'cdrecord -checkdrive', or any other option that exercises the
drive, I get an error message saying 'Invalid lun specifier' and 'Cannot
open
SCSI driver'.

I can't see a place on this page to add an attachment, so I'll try to add
cdrecord.conf, the output from lsmod, the output from 'cdrecord -scanbus',
and the output from 'cdrecord -checkdrive' after filing this.

(I left the priority field at normal, but this is pretty important to me,
because
it prevents me from making regular backups.)

Thanks.

Robert Riches
richesr1@inetarena.com

Comment 1 Robert M. Riches Jr. 2001-02-05 19:02:39 UTC
Created attachment 9062 [details]
/etc/cdrecord.conf

Comment 2 Robert M. Riches Jr. 2001-02-05 19:03:45 UTC
Created attachment 9063 [details]
output of lsmod

Comment 3 Robert M. Riches Jr. 2001-02-05 19:04:34 UTC
Created attachment 9064 [details]
output of cdrecord -scanbus

Comment 4 Robert M. Riches Jr. 2001-02-05 19:05:10 UTC
Created attachment 9065 [details]
output of cdrecord -checkdrive

Comment 5 Robert M. Riches Jr. 2001-02-08 19:14:08 UTC
Created attachment 9439 [details]
context diff between non-working (.~2~) and working (plain) config file.

Comment 6 Robert M. Riches Jr. 2001-02-08 19:14:44 UTC
After a little more experimenting with formatting of white space on the line
that specifies the detailed drive information, I stumbled upon a way to
format the line so that it works.  In an ideal world, white space would be
transparent, but at least there's a way to make it work.

If the man page is generated by Redhat, perhaps a mention of the white
space issue could be included in the man page to guide other clueless
newbie users such as myself.  I'll try to attach a context diff between the
format that did not work and the format that did work.

Depending on what you wish to do regarding possibly updating the
documentation and/or possibly reporting the white space sensitivity issue
to the developer, I'm okay with closing this report.


Comment 7 Crutcher Dunnavant 2001-04-18 16:07:01 UTC
from 'man cdrecord':

Each line that follows a label contains a TAB separates list of items.


Note You need to log in before you can comment on or make changes to this bug.