Bug 26134 - Can't type q and accent with bash in Xterm terminal.
Summary: Can't type q and accent with bash in Xterm terminal.
Status: CLOSED DUPLICATE of bug 26300
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-05 19:04 UTC by Need Real Name
Modified: 2007-04-18 16:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 16:45:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-02-05 19:04:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)


Can't type q and accent in xterm using bash and vi. Other application
(Abiword, Gedit) work well.
There is no problem's out off X11 (console mode).

Reproducible: Always
Steps to Reproduce:
1. Just start X11 with LANG=es and type anything.
2.
3.

Comment 1 Glen Foster 2001-02-05 22:51:28 UTC
We (Red Hat) should really try hard to fix this before next release.

Comment 2 Bernhard Rosenkraenzer 2001-02-05 23:24:37 UTC
Since it doesn't happen in the console, this is not a bash bug.
I guess the xmodmaps for your keyboard layout are off; reassigning to XFree86.

Comment 3 Mike A. Harris 2001-02-08 01:52:29 UTC
I need someone familiar with international keyboard setups to recommend
how to fix this.  You mention if you type q and accent in xterm it doesn't
work.  Please describe the expected behaviour (forgiving me for not having
any experience with other languages, or multinational keyboard setups).

Be as detailed as you can.  If you've any info as to what/where this needs
to be fixed, please let me know.  Right now, I can't replicate the problem
because I don't fully understand it.

Comment 4 Tim Waugh 2001-02-08 17:48:54 UTC
I'm seeing _something_ odd, but I don't know if it's what the original reporter
saw.

1. Spanish NFS workstation install with GNOME and KDE, GNOME preferred
2. Boot to runlevel 3.  Log on as root.  Startx (GNOME starts)
3. Start gnome-terminal.
4. Type a quote and then "e", in order to get "i"

Actual result: The cursor moves forward one space but no glyph appears
Expected result: The cursor moves forward one space and leaves "i" behind

Even weirder: Type "'e" and return and you get:

bash:

(No error message.) If you try to highlight the line then you see:

bash:  : command not found

xterm behaves just fine.
rxvt seems to ignore the quote and you just get a normal "e"
konsole behaves the same as rxvt

So I think this is probably a gnome-terminal/zvt bug.

barreiro@arrakis.es: are we looking at the same bug?

Comment 5 Tim Waugh 2001-02-08 17:51:37 UTC
Hmm, bugzilla doesn't like accents either. :-)

For "i" above, read e-acute.

Comment 6 Havoc Pennington 2001-02-08 23:58:33 UTC
It works with LANG=es_ES, LANG=es isn't correct (there is no es locale).
LANG=es gives me "locale not supported by C library."

Comment 7 Tim Waugh 2001-02-09 00:08:11 UTC
Then anaconda shouldn't put es in /etc/sysconfig/i18n.

Comment 8 Tim Waugh 2001-02-09 15:45:53 UTC
In fact LANG=es_ES@euro; Havoc, this is right, surely?

Comment 9 Havoc Pennington 2001-02-09 16:39:37 UTC
$ LANG=es_ES@euro gnome-terminal

Gdk-WARNING **: locale not supported by Xlib, locale set to C


Comment 10 Tim Waugh 2001-02-09 16:45:17 UTC
So is this another instance of bug 26300?

Comment 11 Havoc Pennington 2001-02-09 17:05:20 UTC
Looks that way to me.

*** This bug has been marked as a duplicate of 26300 ***


Note You need to log in before you can comment on or make changes to this bug.