Bug 261561 - Emacs displays logo screen when arguments include file name
Emacs displays logo screen when arguments include file name
Status: CLOSED DUPLICATE of bug 237105
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
All All
medium Severity low
: ---
: ---
Assigned To: Chip Coldwell
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-08-28 15:50 EDT by Christopher Beland
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-29 13:45:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2007-08-28 15:50:44 EDT
In Fedora 6 and previous releases, if you started Emacs without any arguments on
the command line, you would first get a screen with a giant gnu logo and some
help and version information.  If you clicked on the screen or pressed Ctrl-l as
directed, you would then go to the scratch buffer.  If you supplied a filename
on the command line, the buffer for that file would open immediately after Emacs
finished initializing, with no logo screen.

In Fedora 7, the logo screen *always* appears on startup.  This was fun at
first, but after a few dozen Emacs starts, it has gotten to be quite annoying to
have to click away the logo screen every time I try to edit a file.  Most other
document-editing programs just jump into the requested document, if any.  If
they take a long time to start up, they might display a splashscreen, but Emacs
doesn't need to since it starts up relatively quickly.  And the logo screen does
not go away automatically.

I would also expect it would be less confusing for new users to get the
requested document immediately, instead of something which is not their document
and which takes some reading through to figure out how to get to their document.
 The help information presented by the logo screen is redundant, since Emacs has
a perfectly good "help" screen.  The logo screen is accessible to people looking
for version information by choosing "Help" -> "About Emacs" from the menu system.

I wish I knew the proper LISP incantation to restore the older behavior.
Comment 1 Chip Coldwell 2007-08-29 13:45:11 EDT

*** This bug has been marked as a duplicate of 237105 ***

Note You need to log in before you can comment on or make changes to this bug.