This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 262781 - KGet crashed when downloading files from samba server with 1000Mbps network connection.
KGet crashed when downloading files from samba server with 1000Mbps network c...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kdenetwork (Show other bugs)
5.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Lukáš Tinkl
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-29 05:04 EDT by Jinbing Guo
Modified: 2015-07-13 13:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-01 13:41:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log file of backtrace. (4.47 KB, text/plain)
2007-08-29 05:04 EDT, Jinbing Guo
no flags Details
kget backtrace from RHEL 5.1 x86_64 [1 of 2] (1.28 KB, text/plain)
2008-01-25 15:52 EST, Jeff Bastian
no flags Details
kget backtrace from RHEL 5.1 x86_64 [2 of 2] (3.30 KB, text/plain)
2008-01-25 15:53 EST, Jeff Bastian
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 122587 None None None Never

  None (edit)
Description Jinbing Guo 2007-08-29 05:04:40 EDT
Description of problem:

The client connected the samba server in 1Gbps. When KGet tool was downloading a
big (4.7G) file from the server, it would crash if you clicked the "Transfer ->
Timer" menu. Both the server and client were installed RHEL5. 

Version-Release number of selected component (if applicable):
KGet v0.8.5 (Using KDE 3.5.4-11.el5 Fedora-core) (using KDE KDE 3.5.4) 

How reproducible:
always

Steps to Reproduce:
1. Start the samba server and share a big file.
2. Connect the samba server and client in 1000Mbps.
3. At the client, use the KGet tool to download file from the server.
4. When the downloading speed reachs more than 40 MBps (just an
estimated value), Click the menu "Transfer->Timer".
5. KGet will crash and catch the signal 11.


Actual results:
crashed

Expected results:
no exceptions

Additional info:
Comment 1 Jinbing Guo 2007-08-29 05:04:40 EDT
Created attachment 178581 [details]
log file of backtrace.
Comment 2 Jeff Bastian 2008-01-25 15:49:12 EST
[Changing version to 5.1 and hardware to all.]

I was able to reproduce this on RHEL 5.1 on x86_64.  Using Transfer->Timer is
not necessary, just pause & resume the download a number of times and it will
eventually crash when hitting pause.

Comment 3 Jeff Bastian 2008-01-25 15:52:51 EST
Created attachment 292991 [details]
kget backtrace from RHEL 5.1 x86_64 [1 of 2]

First of 2 more detailed backtraces of a kget crash.  The kdenetwork and
kdelibs debuginfo packages were installed.
Comment 4 Jeff Bastian 2008-01-25 15:53:50 EST
Created attachment 292992 [details]
kget backtrace from RHEL 5.1 x86_64 [2 of 2]

Second of 2 kget detailed backtraces.
Comment 5 Jeff Bastian 2008-01-25 15:55:12 EST
Linked this BZ to http://bugs.kde.org/show_bug.cgi?id=122587

Unfortunately, it looks like this will not be fixed upstream.  They recommend
upgrading to KDE 4.0.

Note You need to log in before you can comment on or make changes to this bug.