Bug 26294 - Error in /etc/rc.d/rc.sysinit
Summary: Error in /etc/rc.d/rc.sysinit
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 35396 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-06 10:30 UTC by Walter Mueller
Modified: 2014-03-17 02:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 18:00:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Walter Mueller 2001-02-06 10:30:40 UTC
booting fisher (and also guinness) gives the error messages 

rm:   /var/run/mon/log.d is a directory
rm:   /var/run/mon/state.d is a directory

line 544 in /etc/rc.d/rc.sysinit reads 
...
# Clean up /var
# I'd use find, but /usr may not be mounted.
for afile in /var/lock/* /var/run/*; do
   if [ -d "$afile" ]; then
      [ "`basename $afile`" != "news" -a "`basename $afile`" != "sudo" ] &&
rm -f $afile/*
   else
      rm -f $afile
   fi
done
...

Comment 1 Bill Nottingham 2001-02-06 18:00:38 UTC
Will be fixed in 5.62-1.

Comment 2 Bill Nottingham 2001-04-10 01:46:04 UTC
*** Bug 35396 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.