Bug 26296 - Error in /etc/rc.d/sockd
Error in /etc/rc.d/sockd
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: dante (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-06 05:35 EST by Walter Mueller
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-27 09:50:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walter Mueller 2001-02-06 05:35:02 EST
in the file /etc/rc.d/sockd two tests are incomplete
...
    23 start() {
     24     # Start daemons.
     25     echo -n $"Starting sockd: "
     26     daemon /usr/sbin/sockd -D
     27     echo
     28     RETVAL=0
     29     [  -eq 0 ] && touch /var/lock/subsys/sockd
     30     return
     31 }
     32 
     33 stop() {
     34     # Start daemons.
     35     echo -n $"Shutting down sockd: "
     36     killproc sockd
     37     RETVAL=0
     38     [  -eq 0 ] && rm -f /var/lock/subsys/sockd
     39     return
     40 }
...
Comment 1 Tim Powers 2001-02-06 11:18:11 EST
The problem is that the spec file was interpreting $?'s and $RETVAL's. This is
fixed in dante-1.1.6-5, and should not reappear sionce the initscript is now a
sourcefile instead of being generated in the spec file.

Thanks for the report.

Tim
Comment 2 Walter Mueller 2001-02-25 07:11:00 EST
This bug still exists in dante-1.1.6-5 (woverine)
Comment 3 Tim Powers 2001-02-25 07:41:27 EST
Can you please make sure that you installed the updated version of dante? I am
looking at the built package right now and the initscript is fine.

Tim
Comment 4 Tim Powers 2001-02-25 09:03:31 EST
Also, check to make sure that the initscript is not a remnant of a previous
installation of dante. That could also be the problem you are having.

Tim
Comment 5 Walter Mueller 2001-02-26 03:04:52 EST
I installed wolverine from scratch using new installation and still get this
error
# ls dante*
dante-1.1.6-5.i386.rpm        dante-server-1.1.6-5.i386.rpm
dante-devel-1.1.6-5.i386.rpm
Comment 6 Tim Powers 2001-02-26 10:40:08 EST
Please make sure that when you remove the dante packages that 
/etc/init.d/sockd is removed as well. I have tested this on two different 
machines today and neither of them are broken.

I am resolving this as rawhide again. Please check to make certain that the 
packages you are lusing are in fact from the wolverine beta.

Tim
Comment 7 Walter Mueller 2001-02-27 01:55:34 EST
I checked it again. I installed the package from the iso image of wolverine and
the error exists!
I just installed dante-1.1.6-5 from the iso-image on a RedHat-7.0 system

/etc/init.d/sockd start
Starting sockd:                                            [  OK  ]
./sockd: [: -eq: unary operator expected

 rpm -qi dante
Name        : dante                        Relocations: (not relocateable)
Version     : 1.1.6                             Vendor: Red Hat, Inc.
Release     : 5                             Build Date: Tue 06 Feb 2001 04:23:58
PM CET
Install date: Tue 27 Feb 2001 07:44:42 AM CET      Build Host:
porky.devel.redhat.com
Group       : Applications/System           Source RPM: dante-1.1.6-5.src.rpm
Size        : 1198770                          License: BSD-type
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.inet.no/dante/
Summary     : A free Socks v4/v5 client implementation
Description :
Dante is a free implementation of the proxy protocols socks version 4,
socks version 5 (rfc1928) and msproxy. It can be used as a firewall
between networks. It is being developed by Inferno Nettverk A/S, a
Norwegian consulting company. Commercial support is available.

This package contains the dynamic libraries required to "socksify"
existing applications to become socks clients.

Top of the RELEASE_NOTES  in /mnt/cdrom reads

Release Notes
--------------

- REQUIREMENTS:  You must have Red Hat Linux 7.1 installed.  All of these 
  packages were built against a 7.1 environment.  If you do not have 
  7.1 installed, you may experience difficulty.  Some of the packages
  require other packages from 7.1 or from this CD. 
  Please make sure you have all the proper libraries installed BEFORE
  submitting a bug report.

Comment 8 Tim Powers 2001-02-27 09:37:31 EST
If this is not on a freshly installed system (ie, you have had dante on that 
before), please check that when you "rpm -e dante-server" that the 
/etc/init.d/sockd file is removed. If it is not, then it has been edited and 
won't be removed by RPM since it is marked as %config in the specfile.

I still can't reproduce this problem, and now I have tried it on four fresh 
installs of wolverine. 

Tim


Comment 9 Tim Powers 2001-02-27 09:50:08 EST
I know ,what you were seeing. We were looking at two totally different things 
in the initscript. You said that the origionoal problem still exists, it does 
(it did), but not the problem reported origionally in the bug report.

I have fixed the problem you complained about when you reopened the bug. The 
initscript was had this [ -eq 0 ] when it should have been this in the stop 
and start sections [ $RETVAL -eq 0 ] .

Tim

Note You need to log in before you can comment on or make changes to this bug.