Bug 2630 - rpm-3.0 on HP-UX 10.20 has problems with command line parsing
rpm-3.0 on HP-UX 10.20 has problems with command line parsing
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-07 05:40 EDT by benedict
Modified: 2015-01-07 18:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-14 14:54:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description benedict 1999-05-07 05:40:39 EDT
I installed rpm-3.0 as compiled out of the box for
HPUX-10.20

The binary seems to have problems somewhere in parsing of
command line arguments, as seen from the following command
examples:

	# rpm
	rpm: unexpected query source

	# rpm --version
	RPM version 3.0
	rpm: unexpected query source
	# rpm --rcfile=/etc/rpmrc --version
	RPM version 3.0
	#
Comment 1 Jeff Johnson 1999-05-13 13:15:59 EDT
Command line parsing in rpm is done with popt. There appears to
be a problem there. Can you supply the HP-UX equivalent of
	strace rpm
so I can begin to guess what's broke?
Comment 2 benedict 1999-05-14 04:41:59 EDT
The problem disappears when rpm is built without optimization.
Seems to be due to a compiler problem, not rpm source.
Comment 3 Jeff Johnson 1999-05-14 14:54:59 EDT
Please reopen this bug if you have a fix.

Note You need to log in before you can comment on or make changes to this bug.