Bug 26300 - X Windows complains about locale settings
Summary: X Windows complains about locale settings
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 26134 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-06 10:44 UTC by Christoph Rohland
Modified: 2007-04-18 16:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 23:32:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christoph Rohland 2001-02-06 10:44:58 UTC
I see a lot of error messages (.e.g in .xsession-errors or when starting 
up xemacs) like:

X Windows does not support locale 'de_DE@euro'

Language settings in the installer was german (+us english)

Comment 1 Glen Foster 2001-02-07 00:06:02 UTC
We (Red Hat) should really try to fix this before next release.

Comment 2 Mike A. Harris 2001-02-07 06:36:04 UTC
I need someone who knows about locales to provide me with a diff or at least
the necessary information to add this support.  I only have part of the
puzzle...
Anyone in the .de office have any idea?

Comment 3 Matt Wilson 2001-02-07 20:58:14 UTC
email jakub@redhat.com, he will help you


Comment 4 Havoc Pennington 2001-02-09 17:04:54 UTC
*** Bug 26134 has been marked as a duplicate of this bug. ***

Comment 5 Mike A. Harris 2001-02-14 00:38:25 UTC
RC1 is tomorrow and I haven't received any info, so it will have to be RC2
material.  I need to know what is needed to be changed for this euro stuff
to play ball.  I think I've found the correct files, but no info.

Comment 6 Trond Eivind Glomsrxd 2001-03-09 04:06:53 UTC
Jakub, you're the one who knows the locale stuff for glibc. Could you please
give some feedback on how to match X locales with these?

Comment 7 Mike A. Harris 2001-03-15 17:18:28 UTC
Fixed in XFree86-4.0.2a-1 in rawhide


Note You need to log in before you can comment on or make changes to this bug.