Bug 26300 - X Windows complains about locale settings
X Windows complains about locale settings
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 26134 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-06 05:44 EST by Christoph Rohland
Modified: 2007-04-18 12:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 18:32:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Rohland 2001-02-06 05:44:58 EST
I see a lot of error messages (.e.g in .xsession-errors or when starting 
up xemacs) like:

X Windows does not support locale 'de_DE@euro'

Language settings in the installer was german (+us english)
Comment 1 Glen Foster 2001-02-06 19:06:02 EST
We (Red Hat) should really try to fix this before next release.
Comment 2 Mike A. Harris 2001-02-07 01:36:04 EST
I need someone who knows about locales to provide me with a diff or at least
the necessary information to add this support.  I only have part of the
puzzle...
Anyone in the .de office have any idea?
Comment 3 Matt Wilson 2001-02-07 15:58:14 EST
email jakub@redhat.com, he will help you
Comment 4 Havoc Pennington 2001-02-09 12:04:54 EST
*** Bug 26134 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2001-02-13 19:38:25 EST
RC1 is tomorrow and I haven't received any info, so it will have to be RC2
material.  I need to know what is needed to be changed for this euro stuff
to play ball.  I think I've found the correct files, but no info.
Comment 6 Trond Eivind Glomsrxd 2001-03-08 23:06:53 EST
Jakub, you're the one who knows the locale stuff for glibc. Could you please
give some feedback on how to match X locales with these?
Comment 7 Mike A. Harris 2001-03-15 12:18:28 EST
Fixed in XFree86-4.0.2a-1 in rawhide

Note You need to log in before you can comment on or make changes to this bug.