Bug 26302 - autofs should be statically linked to LDAP libraries
autofs should be statically linked to LDAP libraries
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
7.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-06 05:47 EST by Phil Mayers
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-06 05:47:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Mayers 2001-02-06 05:47:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


autofs is dynamically linked. Call me crazy, but it really ought to be 
statically linked.

Specifically, any attempt to upgrade to OpenLDAP 2.0 will result in autofs 
not working anymore, since libldap.so.1 and liblber.so.1 don't exists.

I realise this won't occur in the next version of RedHat (since it ships 
with OpenLDAP 2.0) but the principle of the thing:

bash-2.04$ rpm -q --requires autofs
/sbin/chkconfig
/etc/init.d
/bin/bash
mktemp
sed
textutils
sh-utils
grep
/bin/ps
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
ld-linux.so.2
libc.so.6
libdl.so.2
liblber.so.1
libldap.so.1
libnsl.so.1
libresolv.so.2
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libdl.so.2(GLIBC_2.0)
libdl.so.2(GLIBC_2.1)
libnsl.so.1(GLIBC_2.0)
libnsl.so.1(GLIBC_2.1)
rpmlib(CompressedFileNames) <= 3.0.4-1

All of those are OK dependencies, except the LDAP libraries.

This is, of course, all IHMO.

Reproducible: Always
Steps to Reproduce:
1. Install RedHat 7
2. Configure and use autofs
3. rpm -Uvh http://openit.stanford.edu/download/redhat7/RPMS/openldap-
2.0.7-7.i386.rpm
	

Actual Results:  autofs fails if you have any LDAP mounts defined with:

Feb  6 09:36:55 test-pjm3-76 automount[2650]: starting automounter version 
3.1.6, path = /imperial, maptype = ldap, mapname = 
ldap.net.ic.ac.uk:ou=Directory,dc=net,dc=ic,dc=ac,dc=uk
Feb  6 09:36:55 test-pjm3-76 automount[2650]: cannot open lookup module 
ldap (liblber.so.1: cannot load shared object file: No such file or 
directory)


Expected Results:  It should have started

You can fix this with:

cd /usr/lib
ln -s libldap.so.2 libldap.so.1
ln -s liblber.so.2 liblber.so.1

I have no idea if this is safe, but it is avoidable by simply statically 
linking autofs. Given the critical nature of a mount-type component, I 
think this would be a good idea.
Comment 1 Nalin Dahyabhai 2001-02-06 13:44:57 EST
If you have packages which depend on the older versions of the shared libraries,
use the openldap12 binary-compatibility package from Raw Hide to cleanly resolve
the dependencies.  Statically-linking a library is to be avoided unless
absolutely necessary.
Comment 2 Phil Mayers 2001-02-06 17:46:39 EST
Well, personally I'm of the opinion that anything needed at boot-time 
(including possibly the automounter) should have as few dependencies as 
possible, but as I said this problem won't exist in RH >7.0

The main issue, that of 1.2-2.0 compatibility, seems to be solved by this RPM, 
whose existence I wasn't aware of. However, you'll forgive me if I don't 
install it on hundreds of production 7.0 machines :o)

Thanks for the speedy response

Note You need to log in before you can comment on or make changes to this bug.