This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 26330 - Remote port forwarding seems broken
Remote port forwarding seems broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-06 12:42 EST by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 02:14:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-06 12:42:54 EST
The remote port forwarding (-R option) in ssh seems broken in 
openssh-2.3.0p1-4
The local port forwarding (-L options) works OK.
Comment 1 Need Real Name 2001-02-06 12:57:23 EST
The command
ssh -R 6004:localhost:22 user@host.domain.com
does dorward 6004 port on remote machine to port 22 on client machine
on
SSH-2.0-2.0.13 (non-commercial SSH 2.0.13)
and does not do any forwarding on
SSH-1.99-OpenSSH_2.3.0p1 (openssh-2.3.0p1-4)
Comment 2 Pekka Savola 2001-02-06 20:10:48 EST
Did you use Protocol 2 (the default)?

Please note that _remote_ port forwarding for SSHv2 doens't work in 2.3.0p1.

This has been fixed in CVS 2.5 months ago, but no new SSH versions have been 
released yet.
Comment 3 Need Real Name 2001-02-06 20:28:30 EST
Yes, I am using SSH2 protocol.
I will try CVS snapshot when I have time.
Comment 4 Need Real Name 2001-02-06 21:33:34 EST
Seems I can not get CVS snapshot,
because it asks for a login/password to access.

Is there a way to extract this fix from CVS snapshot?

Or, another question: whether older openssh versions 
have remote forwarding working?
Comment 5 Need Real Name 2001-02-06 21:53:00 EST
2.1.1p4-1.i386.rpm does not work withy remote 
port forwarding either.
Comment 6 Pekka Savola 2001-02-07 02:14:54 EST
CVS uses 'anoncvs' or 'anonymous' pass I recall.

Snapshots can be obtained from http://www.mindrot.org/misc/openssh/

Some other stuff has changed too, so ripping the patch out and inserting it to 2.3.0p1 
might be problematic.
Comment 7 Pekka Savola 2001-02-24 03:15:33 EST
2.5.1p1, where problems like these should have been fixed, is (will be) in rawhide.

Note You need to log in before you can comment on or make changes to this bug.