Bug 26344 - openssh 2.3.0p1 may ask for DSA password in batch mode
Summary: openssh 2.3.0p1 may ask for DSA password in batch mode
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-06 19:00 UTC by Jay Berkenbilt
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-24 06:20:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch mentioned in bug report (650 bytes, patch)
2001-02-06 19:01 UTC, Jay Berkenbilt
no flags Details | Diff

Description Jay Berkenbilt 2001-02-06 19:00:01 UTC
With no agent running

ssh host -o "Protocol 1" -o "BatchMode yes"

will fail without prompting for a password, as it should.  However

ssh host -o "Protocol 2" -o "BatchMode yes"

will prompt for a password.  The following patch, relative to the
BUILD/openssh-2.3.0p1 directory after rpm -bp SPECS/openssh.spec (on
the Fisher src.rpm) has been run, fixes the problem.  This change was
made by shamelessly copying code from sshconnect1.c into
sshconnect2.c, though there certainly seems to be good precedent for
doing that. :-)

I have also reported this to openssh@openssh.com (with a patch
relative to the clean sources, offset from this by 14 lines).

I am attaching the patch to this bug report as a file.

Comment 1 Jay Berkenbilt 2001-02-06 19:01:04 UTC
Created attachment 9159 [details]
patch mentioned in bug report

Comment 2 Jay Berkenbilt 2001-02-22 14:36:27 UTC
FWIW, openssh 2.5.1p1 fixes this problem and also implements -R and agent
forwarding for ssh2 as well as sftp.  Maybe it's a pipe dream that this could be
included in 7.1 but it sure would be nice. :-)

Comment 3 Jay Berkenbilt 2001-02-24 06:20:02 UTC
This bug and others are fixed in the recently released openssh 2.5.1p1.

Comment 4 Pekka Savola 2001-02-24 08:12:01 UTC
2.5.1p1 is (will be) in rawhide.


Note You need to log in before you can comment on or make changes to this bug.