Bug 26363 - upgrade fails on a UP1000
Summary: upgrade fails on a UP1000
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-06 21:45 UTC by Need Real Name
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 21:51:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-02-06 21:45:04 UTC
raceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in
doInstall
    if self.method.systemMounted (self.fstab, self.instPath,
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 63, in
systemMounted
    isys.lochangefd("/tmp/loop", self.loopbackFile)
  File "/usr/lib/anaconda/isys.py", line 55, in lochangefd
    _isys.lochangefd(loop, targ)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
file: /mnt/sysimage/home/rhinstall-stage2.img
loop: 15
targ: 16
device: /tmp/loop
ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I1
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hdc'
sS'progressWindow'
p9

<failed>

System: UP1000  (booting with API apb.exe)

Comment 1 Matt Wilson 2001-02-07 20:07:24 UTC
you are using the stock kernel to boot, yes?


Comment 2 Need Real Name 2001-02-07 21:49:25 UTC
Right!. If I copy the kernell from cdrom/kernells instead of the diskette image.
I can do the upgrade.
Thanks.



Comment 3 Matt Wilson 2001-02-07 21:51:16 UTC
no worries, not a bug then. :)



Note You need to log in before you can comment on or make changes to this bug.