Bug 26460 - upgrade adds packages
Summary: upgrade adds packages
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-07 14:06 UTC by Gene Czarcinski
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 00:01:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result of rpm-qa on rhl-7.0 custom install (5.54 KB, text/plain)
2001-02-08 01:22 UTC, Gene Czarcinski
no flags Details
rpm -qa after fisher upgrade (6.55 KB, text/plain)
2001-02-08 01:23 UTC, Gene Czarcinski
no flags Details
install log from rhl-7.0 custom install (7.07 KB, text/plain)
2001-02-08 01:24 UTC, Gene Czarcinski
no flags Details
update log from fisher upgrade (62.61 KB, text/plain)
2001-02-08 01:24 UTC, Gene Czarcinski
no flags Details

Description Gene Czarcinski 2001-02-07 14:06:45 UTC
I did a clean install of rhl 7.0.  I then ran an upgrade of beta3.  The
upgrade install a large number of "extra" packages which were NOT on the
original system.  These extras included emacs and all of the various email
and news reader packages.  Manually deselecting these packages did not
result in any dependency problems.

Comment 1 Michael Fulbright 2001-02-07 16:24:50 UTC
What type of 7.0 install did you do - the more specific you can be about the
packages/components you selected would really help us.

Comment 2 Gene Czarcinski 2001-02-07 22:04:49 UTC
If you need the info, I can build the rhl 7.0 system again and do q "rpm -qa" to
get you the complete list accurately.

However, it was a custom install with gnome, only kdesupport, kdebase, kdelibs,
kdelibs-sound, and kdenetwork for kde, and printer support.  I knew it was doing
this so I tried to keep it simple.  I did NOT install any of emacs, the various
mail packages (except kmail in kdenetwork), or the news reader.

It seems to be ver repeatable.

Comment 3 Gene Czarcinski 2001-02-08 01:21:25 UTC
OK, I did a rhl-7 custom install and then a fisher upgrade.  Attached are the
rpm -qa results and the install/upgrade logs.

Comment 4 Gene Czarcinski 2001-02-08 01:22:36 UTC
Created attachment 9379 [details]
result of rpm-qa on rhl-7.0 custom install

Comment 5 Gene Czarcinski 2001-02-08 01:23:23 UTC
Created attachment 9380 [details]
rpm -qa after fisher upgrade

Comment 6 Gene Czarcinski 2001-02-08 01:24:04 UTC
Created attachment 9381 [details]
install log from rhl-7.0 custom install

Comment 7 Gene Czarcinski 2001-02-08 01:24:44 UTC
Created attachment 9382 [details]
update log from fisher upgrade

Comment 8 Glen Foster 2001-02-08 16:03:30 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 9 Matt Wilson 2001-02-08 17:46:48 UTC
fixed in CVS.  It was applying the default Component (package group) selections
to upgrades.

I can provide an updates disk if you want to test this.  mail msw@redhat.com



Note You need to log in before you can comment on or make changes to this bug.