Bug 265 - FTP client can't connect on ports numbers > 32767, reports error
FTP client can't connect on ports numbers > 32767, reports error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
5.2
All Linux
low Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-02 14:57 EST by ah313
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-15 18:18:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ah313 1998-12-02 14:57:00 EST
When trying to connect to a FTP site that runs on a port
greater than 32767, the ftp client reports it's a bad
port.  This is not true because a port can be a 16 bit
integer, but for some reason the FTP client thinks it
is 15 bit!!!
Comment 1 Jeff Johnson 1998-12-04 15:26:59 EST
The port entered from the command line of the ftp client
is inconsistently copied from int to short to u_short ...
Comment 2 Cristian Gafton 1998-12-15 18:18:59 EST
Fixed in the ftp-0.10-4 and later, which will be available from
rawhide.

Note You need to log in before you can comment on or make changes to this bug.