Bug 26572 - up2date pkgSkipList too broad
up2date pkgSkipList too broad
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-07 18:39 EST by Hunter Matthews
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 01:59:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hunter Matthews 2001-02-07 18:39:35 EST
pkgSkipList=kernel*; is going to ignore all kernel-blah.blah pkgs, which is
what you want,
but will also ignore all kernelcfg pkgs, which is probably not what you
want. 

kernel-* might look like a way out, but that ignored kernel-pcmcia-cs and
kernel-utils, but 
not kernel-VERSION  itself.

Right now, there doesn't appear to be a way to ignore the kernel without
also ignoring every
possible package that starts with "kernel". Maybe not to bad today, until
you errata kernelcfg.
Comment 1 Adrian Likins 2001-02-08 01:59:20 EST
you can use something like:

pkgSkipList=kernel,kernel-pcmcia,kernel-smp,

But your right, this needs to be modified in the default configufation.

Luckily I dont think we'll be doing a kernelcfg errta anytime soon
except maybe `rpm -e kernelcfg` ;->
Comment 2 Preston Brown 2001-02-08 22:33:09 EST
chances of us errata'ing kernelcfg are NIL.
Comment 3 Hunter Matthews 2001-02-09 11:55:48 EST
What are the chances of you errating any package with the same kind of name
conflict as a pkg glob that a user has set in up2date? kernelcfg was just one
example.

"We won't errata kernelcfg" does NOT fix this bug. Sorry.

I don't have a complete 7.0 on my box - are there no other name clashes
involving:
gnome-
kde*
etc etc? Are there going to be any new pkgs that have name conflicts like that?
kde* when the kde team decides to make a base "kde" pkg would trigger this
nicely.
Comment 4 Jay Turner 2001-02-28 09:58:53 EST
The reason that kernel* is on the list is becuase we don't have a really good
way of dealing with the kernel errata at this point.  User intervention is still
necessary to get lilo.conf setup and run, so we threw it on the list.  If users
choose to put something like "kde*" on their excludes list, then so be it.  Red
Hat will not ship a default config with that.
Comment 5 Jay Turner 2001-02-28 09:59:18 EST
The reason that kernel* is on the list is becuase we don't have a really good
way of dealing with the kernel errata at this point.  User intervention is still
necessary to get lilo.conf setup and run, so we threw it on the list.  If users
choose to put something like "kde*" on their excludes list, then so be it.  Red
Hat will not ship a default config with that.

Note You need to log in before you can comment on or make changes to this bug.