Bug 26633 - [noapic] SCSI Timeout Errors on NCR53c1510D / sym53c1510D
[noapic] SCSI Timeout Errors on NCR53c1510D / sym53c1510D
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-07 21:41 EST by Richard Black
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 18:10:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Black 2001-02-07 21:41:57 EST
Red Hat Linux Beta - beta3
Feb 7, 2001
Passing HW: ML370 (no ROC)
Failing HW: DL360 (no ROC), ML570 (no ROC)

SCSI Timeout Errors on NCR53c1510D / sym53c1510D

After successful installation and after rebooting, the system displays the 
following repeating error:

SCSI host 0 abort PID90) times out-resetting
SCSI bus is being reset for host 0 channel 0
sym53c8xx_reset PID=0, reset flags=2

Tried 3 separate ML570s and one DL360.

ML370 has the same chipset and installs OK.

Duplicatable: Yes.

Compaq Bug #: 194115

Compaq consideres this defect a  MUST-FIX for Florence.
Comment 1 Glen Foster 2001-02-08 18:43:19 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 2 Glen Foster 2001-02-09 18:19:01 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 3 Michael K. Johnson 2001-02-14 15:18:10 EST
Does this hardware work with the 2.2 kernel?
Does the ncr53c8xx driver work with this hardware?
Comment 4 Michael K. Johnson 2001-02-28 10:11:46 EST
Does the boot argument "noapic" affect this?
Comment 5 Michael K. Johnson 2001-02-28 22:23:33 EST
Also, have you tried changing the OS type in the bios?

Answers to these questions would make it a lot easier for us to
try to track these down...
Comment 6 Michael K. Johnson 2001-03-12 15:45:37 EST
If we do not get feedback on this report, we won't have much else to
do with it other than close it...
Comment 7 Richard Black 2001-03-14 12:53:54 EST
The following SCSI issues should prove to be dependent upon the APIC fix found 
in Linux Kernel 2.4.2-patch5.  These SCSI issues are being tested at this time, 
now that the latest beta seems to have the needed patch.

30170 - Full-Table-Mapped APIC mode causes a problem with installing Kernel 
Linux version 2.4.1-0.1.9smp or later.
26632 - Cannot install to a Compaq array controller - hang
26633 - SCSI Timeout Errors on NCR53c1510D / sym53c1510D
26634 - [aic7xxx] Kernel Bug, 64bit slot, adaptec ctrlr, DL360
Comment 8 Richard Black 2001-03-19 10:14:38 EST
qa0309 does not have the fix needed.  Drivers still error out (timeouts, 
hangs, ...)
Comment 9 Bryan Leopard 2001-03-22 19:14:20 EST
This information was already forwarded to RedHat.  Just wanted to update 
Bugzilla.

I think weve found the problem thats breaking SMP/APIC support on ServerWorks 
servers.
It appears that when the 2.4.0 kernel was released (on Jan. 4), that an old 
version of drivers/ide/osb4.c crept back in.  Whenever we build a kernel with 
this suspect version enabled, it breaks SMP APIC interrupts.
If you do a diff of osb4.c from 2.4.0-prerelease and 2.4.0, youll find a ton 
of changes.  Our guess is that its one of these changes (probably chipset 
initialization) thats breaking APIC support with SMP kernels.


Here is some more information from our developers.

The below fix works!

I see 2 basic ways for this bug to be fixed:

1) Make sure that the

CONFIG_BLK_DEV_OSB4

line in the kernel .config file is NOT set, or

2) Replace the osb4.c file with the osb4.c file from the 2.4.0-prerelease 
source tree.
  (this is probably a better solution)
Comment 10 Bob Matthews 2001-03-23 16:25:21 EST
CONFIG_BLK_DEV_OSB4 is off in all our config files
Comment 11 Bob Matthews 2001-03-23 16:39:39 EST
Waiting for Compaq to officially confirm fix.
Comment 12 John Cagle 2001-03-23 18:10:37 EST
Compaq confirms that the 2.4.2-0.1.35smp kernel (with CONFIG_BLK_DEV_OSB4 
turned OFF) resolves the SCSI Timeout and CPQARRAY lockups during post-
installation boot.

HOWEVER, Compaq would also like to see the CONFIG_BLK_DEV_OSB4 option marked as 
EXPERIMENTAL in drivers/ide/Config.in in all Florence kernel packages, as well 
as in the "ac" series kernels.  This will keep customers from easily stumbling 
across this problem.
Comment 13 Arjan van de Ven 2001-03-26 09:17:50 EST
This driver is now marked as "Dangerous" in our kernelsource.
Alan has agreed to this concept and the patch will be mailed to him in a few
minutes.

Note You need to log in before you can comment on or make changes to this bug.