Bug 266341 - nagios avc denials
nagios avc denials
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.0
All All
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 02:34 EDT by Wart
Modified: 2008-05-21 12:05 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0465
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:05:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wart 2007-08-30 02:34:22 EDT
Description of problem:
An installation of nagios from EPEL-5 generates avc denials.  The first is due
to a bad file path:

# grep nagios /etc/selinux/targeted/contexts/files/file_contexts
/usr/lib(64)?/nagios/cgi/.+ --      system_u:object_r:nagios_cgi_exec_t:s0
[...]

This should be:

/usr/lib(64)?/nagios/cgi-bin/.+ --

The second is a failure for nagios command cgi to schedule commands with the
nagios external command interface because the cgi is unable to write
/var/spool/nagios/cmd/nagios.cmd.  This can be fixed with the following rules:

allow nagios_cgi_t var_spool_t:dir search;
allow nagios_cgi_t var_spool_t:fifo_file { getattr write };

Using a custom 'nagios_spool_t' might be more secure because it would prevent
nagios from reading anything else in /var/spool/...
Comment 1 Daniel Walsh 2007-09-01 07:26:18 EDT
Fixed in selinux-policy-2.4.6-88.el5.src.rpm

Comment 2 RHEL Product and Program Management 2008-01-30 14:15:41 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 errata-xmlrpc 2008-05-21 12:05:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0465.html

Note You need to log in before you can comment on or make changes to this bug.