Bug 266441 - php timezone database
php timezone database
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: php (Show other bugs)
5.0
All All
high Severity low
: ---
: ---
Assigned To: Joe Orton
:
: 440355 (view as bug list)
Depends On:
Blocks: 372911
  Show dependency treegraph
 
Reported: 2007-08-30 04:37 EDT by Joe Orton
Modified: 2008-05-21 10:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0327
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:31:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2007-08-30 04:37:09 EDT
Description of problem:
PHP 5 has a hard-coded copy of the timezone database in the "date" extension. 
It should be possible to change this to load the data from /usr/share/zoneinfo.

Version-Release number of selected component (if applicable):
5.1.6-12.el5
Comment 2 RHEL Product and Program Management 2007-10-15 23:43:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Jay Turner 2007-11-22 07:15:07 EST
Qe ack for RHEL5.2.  The sooner we rid ourselves of multiple copies of the
timezone database the better.
Comment 7 John Newbigin 2008-04-02 18:43:59 EDT
This is also an issue for RHEL4 AppStack and possibly others.
Comment 8 Joe Orton 2008-04-03 05:10:27 EDT
*** Bug 440355 has been marked as a duplicate of this bug. ***
Comment 9 Joe Orton 2008-04-03 06:34:46 EDT
jn@, yes, indeed, thanks.  I filed bug 440391 to track this for AppStack V1; the
fix is already integrated for future V2 updates.
Comment 10 errata-xmlrpc 2008-05-21 10:31:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0327.html

Note You need to log in before you can comment on or make changes to this bug.