Bug 266661 - Dell D620 does not wake up from suspend
Dell D620 does not wake up from suspend
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: acpid (Show other bugs)
5.1
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Zdenek Prikryl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 06:42 EDT by Huzaifa S. Sidhpurwala
Modified: 2009-04-08 03:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 03:32:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2007-08-30 06:42:58 EDT
Description of problem:
Dell D620 when installed with RHEL 5.1 beta does not wake up from suspend

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Suspend the laptop
2. Try to wake it up, hangs
  
Actual results:
Does not wake up

Expected results:
Should wake up

Additional info:
[root@huzaifas ~]# lspci 
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 01)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE
Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS
110M/GeForce Go 7300] (rev a1)
03:01.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus
Controller (rev 40)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5752 Gigabit
Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
Comment 1 Huzaifa S. Sidhpurwala 2007-08-30 06:47:43 EDT
This laptop is one of the laptops which the Help Desk within Red Hat is trying
to certify for internal deployment.
So it is very important that we have all the essential features working.
Comment 2 Zdenek Prikryl 2007-08-30 07:10:20 EDT
How do you suspend the laptop? Via pm-utils or gnome-pover-manager or something
else? Could you write version of your kernel, pm-utils, gnome-power-manager?
What driver do you use in xorg.conf in section "Device"?

If you wake up the laptop, can you login via ssh (or ping the laptop)? Even if
screen is black?

Thanks

Zdenek
Comment 3 Huzaifa S. Sidhpurwala 2007-08-30 23:17:38 EDT
Suspend is via: gnome-power-manager
kernel version : 2.6.18-43.el5
pm-utils: 0.99.3-6.el5.12
gnome-power-manager: 2.16.0-8.el5

in the Xorg device uses: VideoCard0

Once the laptop tries to wake up, it cannot be pinged to sshed.

Thanks
Comment 4 Zdenek Prikryl 2007-08-31 02:59:26 EDT
As I found, probably the best solution for this, is upgrade the whole system to
the latest nightly build. There are a few important updates (kernel,
selinux-policy, pm-utils,...) which could lead to working suspend/resume.

After upgrade try to suspend/resume, and even if the screen is black, try ssh or
ping again.

"VideoCard0" is only "Identifier" in section "Device", I would like to know
"Driver" ("nv" or "nvidia" or something else).

Zdenek
Comment 5 Phil Knirsch 2007-09-06 10:13:04 EDT
Thats really strange. We've been doing D620 tests here locally quite a bit
lately, and on all our tests so far on Nvidia and Intel works nicely.

Read ya, Phil
Comment 6 Phil Knirsch 2007-09-07 10:26:05 EDT
I've just verified it, the D620 with Nvidia graphics chip has the same hardware
as you listed, and we've successfully suspended and hibernated that machine with
proper resume.

Please post the exact version of your kernel and hal packages as well please,
maybe that will give us a hint.

Thanks,

Read ya, Phil
Comment 7 Huzaifa S. Sidhpurwala 2007-09-09 23:05:45 EDT
Hi Phil,
  I have lost the hardware to the user, so it will take some time for me to get
it tested.
Will get you the info as soon as i get the hardware back
Comment 8 Huzaifa S. Sidhpurwala 2007-09-10 23:18:42 EDT
I have got the test hardware back, will send you info asap.
Comment 9 Huzaifa S. Sidhpurwala 2007-09-11 01:35:16 EDT
kernel: 
[root@huzaifas ~]# uname -r
2.6.18-45.el5
hal:
[root@huzaifas ~]# rpm -q hal
hal-0.5.8.1-23.el5

Note:
This is the latest 5.1 beta kernel.
Also now the machine can be pinged or sshed to, after it wakes up.
Comment 10 Phil Knirsch 2007-09-11 10:42:31 EDT
The tree currently is missing the latest versions of pm-utils and hal.

Could you give it a try with pm-utils-0.99.3-6.el5.14 or newer and
hal-0.5.8.1-24.el5 or newer? Those can be found on porkchop under /mnt/brew/packages

Thanks,

Read ya, Phil
Comment 11 Huzaifa S. Sidhpurwala 2007-09-11 23:01:40 EDT
Hi Phil,
Put the newest el5 packages for hal and pm-utils from brewroot/packages on porkchop.
The versions are:
  
[root@huzaifas ~]# rpm -q hal
hal-0.5.8.1-24.el5
[root@huzaifas ~]# rpm -q pm-utils
pm-utils-0.99.3-6.el5.15

But, now a strange this has happened.
The machine does not suspend at all.
I am using the gnome-power-manager to suspend it.

When i try to suspend it the screen goes blank.
The cursor is visible on the left top corner of the screen
The mouse works. similar to how it works in text mode.
The keyboard is not active.
I can ping and also ssh to the machine.
Comment 12 Radek Bíba 2007-10-01 09:19:24 EDT
My problems with suspend/resume on a D620 laptop using gnome-power-manager are
gone with the following versions of key packages:

pm-utils-0.99.3-6.el5.16
hal-0.5.8.1-25.el5
kernel-2.6.18-52.el5
selinux-policy-2.4.6-101.el5

These packages can be found in the latest nightly builds of RHEL 5.1. Can you
update your system and try again? Thanks.
Comment 13 Radek Bíba 2007-11-12 11:27:09 EST
Huzaifa, can you try RHEL 5.1 (+day0 updates), please?
Comment 14 Help Desk Reseach and Developement 2008-02-21 05:51:45 EST
[huzaifas@huzaifas ~]$ lspci 
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 01)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE
Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS
110M/GeForce Go 7300] (rev a1)
03:01.0 CardBus bridge: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus
Controller (rev 40)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5752 Gigabit
Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)

[huzaifas@huzaifas ~]$ uname -r
2.6.18-79.el5

[huzaifas@huzaifas ~]$ rpm -q pm-utils hal selinux-policy
pm-utils-0.99.3-6.el5.18
hal-0.5.8.1-33.el5
selinux-policy-2.4.6-121.el5

Same problem, with 5.2 tree now
Comment 15 Help Desk Reseach and Developement 2008-02-21 05:52:38 EST
After wakeup the laptop can be pinged, sshed too, but the display is blank.
Comment 16 Zdenek Prikryl 2008-02-27 08:56:59 EST
Since rbiba's Dell D620 suspend/resume functions work fine in 5.1, so could you
please test it on another laptop (same type)? We haven't tested suspend in 5.2,
but suspend in 5.1 should work.
Comment 17 Zdenek Prikryl 2008-02-28 08:45:47 EST
It seems, that your problem with 5.2 is caused by selinux. Please, try to
suspend/resume and look into /var/log/messages. Probably you'll find something
like this "SELinux is preventing vbetool (vbetool_t) "mmap_zero" to <Unknown>
(vbetool_t)". So, disable your selinux (or set it into permissive mode) and try
to suspend/resume again. We'll see if this is the source of problems.
Comment 18 Huzaifa S. Sidhpurwala 2009-04-08 03:16:42 EDT
works with 5.3
Comment 19 Zdenek Prikryl 2009-04-08 03:32:21 EDT
OK, so I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.