Bug 26718 - exit status of killproc
Summary: exit status of killproc
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-08 20:31 UTC by Gerald Teschl
Modified: 2014-03-17 02:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 22:35:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2001-02-08 20:31:07 UTC
Shouln't killproc exit with 1 if the process is not running at all so that
a user
knows that something is wrong? In particular since you signal "failure" in
this
case.

--- functions.orig      Thu Feb  8 21:26:06 2001
+++ functions   Thu Feb  8 21:26:11 2001
@@ -190,6 +190,7 @@
                fi
        else
            failure $"$base shutdown"
+           RC=1
        fi
 
         # Remove pid file if any.

Comment 1 Bill Nottingham 2001-02-12 22:35:19 UTC
Will be fixed in 5.64-1 or so - thanks!


Note You need to log in before you can comment on or make changes to this bug.