Bug 26764 - bind needs patch for building against glibc cvs
bind needs patch for building against glibc cvs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-08 19:44 EST by Jack Howarth
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 18:09:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Howarth 2001-02-08 19:44:59 EST
The following patch is required to build bind against glibc cvs because of
the
time header changes...

diff -uNr bind-9.1.0/lib/isc/unix/stdtime.c
bind-9.1.0.new/lib/isc/unix/stdtime.c
--- bind-9.1.0/lib/isc/unix/stdtime.c	Wed Jan 17 18:42:41 2001
+++ bind-9.1.0.new/lib/isc/unix/stdtime.c	Sun Feb  4 17:50:11 2001
@@ -19,7 +19,7 @@
 
 #include <config.h>
 
-#include <sys/time.h>
+#include <time.h>
 
 #include <isc/stdtime.h>
 #include <isc/util.h>
Comment 1 Glen Foster 2001-02-09 18:09:11 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Bernhard Rosenkraenzer 2001-02-13 10:01:51 EST
Fixed in 9.1.1-0.2

Note You need to log in before you can comment on or make changes to this bug.