Bug 26766 - patch required to build finger against glibc cvs
Summary: patch required to build finger against glibc cvs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: finger   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: Aaron Brown
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-09 00:59 UTC by Jack Howarth
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 23:09:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jack Howarth 2001-02-09 00:59:25 UTC
Because of the time header changes in glibc cvs, the following patch is
required
to build finger...

diff -uNr bsd-finger-0.17-pre20000412/finger/lprint.c
bsd-finger-0.17-pre20000412.new/finger/lprint.c
--- bsd-finger-0.17-pre20000412/finger/lprint.c	Tue Sep 14 06:51:11 1999
+++ bsd-finger-0.17-pre20000412.new/finger/lprint.c	Sun Feb  4 17:57:08
2001@@ -48,7 +48,7 @@
 #include <sys/types.h>
 #include <sys/file.h>
 #include <sys/stat.h>
-#include <sys/time.h>
+#include <time.h>
 #include "finger.h"
 
 static void lprint(PERSON *pn);
diff -uNr bsd-finger-0.17-pre20000412/finger/sprint.c
bsd-finger-0.17-pre20000412.new/finger/sprint.c
--- bsd-finger-0.17-pre20000412/finger/sprint.c	Sun Dec 12 13:59:33 1999
+++ bsd-finger-0.17-pre20000412.new/finger/sprint.c	Sun Feb  4 17:57:22
2001@@ -40,7 +40,7 @@
 #endif /* not lint */
 
 #include <sys/types.h>
-#include <sys/time.h>
+#include <time.h>
 #include <stdio.h>
 #include <stdlib.h>
 #include <string.h>

Comment 1 Glen Foster 2001-02-09 23:09:15 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 2 Crutcher Dunnavant 2001-02-12 20:38:43 UTC
fixed.


Note You need to log in before you can comment on or make changes to this bug.