Bug 26767 - patch required to build netpbm against glibc cvs
Summary: patch required to build netpbm against glibc cvs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netpbm   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Brian Brock
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-09 01:01 UTC by Jack Howarth
Modified: 2015-03-05 01:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 23:09:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jack Howarth 2001-02-09 01:01:58 UTC
Because of the time header changes a patch is required to build netpbm
against
glibc cvs. While I am not sure if this is the best patch to use...the
following does allow
netpbm to compile...

diff -uNr netpbm-9.9/pnm/fiasco/lib/misc.c
netpbm-9.9.new/pnm/fiasco/lib/misc.c
--- netpbm-9.9/pnm/fiasco/lib/misc.c	Sat Feb  3 22:44:19 2001
+++ netpbm-9.9.new/pnm/fiasco/lib/misc.c	Sat Feb  3 22:45:41 2001
@@ -23,7 +23,6 @@
 #include <ctype.h>
 
 #ifdef TIME_WITH_SYS_TIME
-#	include <sys/time.h>
 #	include <time.h>
 #else  /* not TIME_WITH_SYS_TIME */
 #	if HAVE_SYS_TIME_H

Comment 1 Glen Foster 2001-02-09 23:09:19 UTC
We (Red Hat) should really try to resolve this before next release.


Note You need to log in before you can comment on or make changes to this bug.