Bug 26768 - patch required to build trn against glibc cvs
patch required to build trn against glibc cvs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: trn (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-08 20:04 EST by Jack Howarth
Modified: 2014-03-16 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 20:04:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Howarth 2001-02-08 20:04:27 EST
Because of time header changes in glibc cvs, a patch is required to build
trn against glibc cvs. The following patch allows trn to compile...



diff -uNr trn-3.6/config.h trn-3.6.new/config.h
--- trn-3.6/config.h	Sun Feb  4 17:36:48 2001
+++ trn-3.6.new/config.h	Sun Feb  4 17:37:40 2001
@@ -400,7 +400,7 @@
  *	include <sys/time.h>.
  */
 /*#define I_TIME		*//**/
-#define I_SYS_TIME		/**/
+#define I_TIME		/**/
 
 /* NEWSLIB:
  *	This symbol contains the name of the directory serving as the news
Comment 1 Trond Eivind Glomsrxd 2001-02-08 21:56:57 EST
This is fixed in  trn-3.6-28. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.